After Installing HID Omnikey 3121 driver, Users Still Unable to Read MyKad Details with the 'No card detected' Message Prompted

Problem (Issue) Statement:

After installing the Omnikey 3121 driver, users still unable to read MyKad details with the 'No card detected' error message prompted

Description:

After installing the Omnikey 3121 driver to the PC containing the xPortalNet Client software, the 'No Card Detected' error message is still prompted when users attempt to read MyKad details via the Omnikey 3121.

Related Software:

/wiki/spaces/SRN/pages/97354177

Related Hardware:

HID Omnikey 3121

System Application:

Visitor Management System

Symptom and Finding:

Even after installing the correct device driver for Omnikey 3121, users are still unable to use Omnikey 3121 to read MyKad details in visitor registration. Software prompted the 'No Card Detected' error message as shown in the figure below:
No card detected Window
Figure 1: 'No card detected' Error Message.

When users verified if the PC detected the Omnikey 3121, the device manager indicated that the Omnikey 3121 is detected as 'Microsoft Usbccid Smartcard Reader (WUDF), as shown in the following figure:
Device Manager Window
Figure 2: Show on Device Manager> Device list > Smart card readers> Microsoft Usbccid Smartcard Reader (WUDF).

Cause:

Windows operating system does not recognize the newly installed driver as a driver for the HID Omnikey 3121 Smart Card Reader.

Solution:

Summary

  • To update HID Omnikey 3121 driver from Device List.

Step-by-step Guide:

  • To update HID Omnikey 3121 driver from Device List:

Step 1: Launch 'Computer Management' by right-clicking Computer icon and the select Manage.
To open Device Manager

Figure 3: Right-Click on Computer and Click Manage


Step 2: Go to Device Manager and expand the Smart card readers section.
Expand Smart Card Readers Section

Figure 4: Expand the Smart Card Readers Section


Step 3: Right-click on Microsoft Usbccid Smartcard Reader (WUDF), then run Update Driver Software
To Run Update Driver Software

Figure 5: Click Update Driver Software to Update the HID Omnikey 3121 Driver


Step 4: In the next window, select Browse my computer for driver software. Then, select Let me pick from a list of device driver on my computer and click Next button.
Update Driver Software Window

Figure 6: Selecting Browse My Computer for Driver Software



Update Driver Software Window

Figure 7: Selecting Let Me Pick from a List of Device Drivers on My Computer


Step 5: The Update Driver Software – Microsoft Usbccid Smartcard Reader (WUDF) window will be shown. Check the Show compatible hardware checkbox and select Omnikey 3x21 as the model. Click Next to begin updating the driver.
Update Driver Software Window

Figure 8: Selecting Omnikey 3x21 as the Device Driver to be Installed


Step 6: When Windows has successfully updated the HID Omnikey 3121 driver, the following window will be shown. Click Close to exit.
Update Driver Software Window

Figure 9: Driver Software Installation Success Window


Step 7: Go to device manager to verify that the Windows operating system indeed has recognized the smart card reader as Omnikey 3x21. Users can now use the HID Omnikey 3121 to read MyKad details.
Expand Smart Card Readers Section in Device Manager

Figure 10: Verifying that the Correct Device Driver is installed

Date Documentation:

29/3/2018 (Rev 1.0)

PROOF-READ

.

.


.

© MicroEngine Technology Sdn Bhd (535550-U). All rights reserved.