Why is the "User Already Login" Error Message Shown When Login to the xPortalNet Software


Problem (Issue) Statement:

Why is the "User Already Login" error message shown when login to the xPortalNet software

Description:

"User Already Login" error message is shown due to the user account is currently in used or account session was not terminated correctly when closing the software application.

Related Software:

NIL

Related Hardware:

NIL

System Application:

Door Access System

Symptom and Finding:

The following error message is shown when login to the software / when try to re-login after software is unexpectedly terminated. 
User Already Login error message
Figure 1: User Already Login error message.

Cause:

  • The user account really is in used at the moment.
  • The user did not logout properly from the software due to Client application terminated unexpectedly (eg. the process was killed by user, Windows restarted due to power interruption, application stopped working due to unforeseen exception)

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary 

  • To Terminate Current Logged in System User.


Step-by-step Guide: 

  • To Terminate Current Logged in System User:

In these steps, user will be guided to terminate current logged in System User session to be used in new session.

Important

If the user account is really in used at the moment, please confirm the login status with the System Administrator before terminating the session.

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Step 1: Run the xPortalNet Server.


Step 2: Log in using other System User account. 


Step 3: At Connected Software User List, please select the account to be terminated.
Connected Software User List
Figure 2: Connected Software User List.


Step 4: Then, click on the Disconnect User at the bottom of the window.
Click Disconnect User
Figure 3: Click Disconnect User.


Step 5: You will be prompted to confirm the termination. Click Yes to continue.
Confirm user termination
Figure 4: Confirm user termination.


Step 6: The account has been terminated message will be displayed. Click OK.
Account successfully terminated message
Figure 5: Account successfully terminated message.


Step 7: Session terminated message will be shown once the account has been terminated. Click OK.
User Session Has Been Terminated message
Figure 6: User Session Has Been Terminated message.

Information

You will notice that the terminated System User will no longer be listed in the Connected Software User List.

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Step 8: Re-login to the software by using the same account.


Step 9: Finished.

Document Date

03/09/2018  (Rev 1.0)

PROOF-READ

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