How to Setup Purge Visitor in xPortalNet Software


Problem (Issue) Statement:

How to Setup Purge Visitor in xPortalNet Software

Description:

A guide to configure the Action Procedures Purge Visitor. By executing this action, the system will delete the existing visitor records.

For Visitor Management System, visitors frequently sign in to the software on a daily basis. After visitors signed out, user can use the same ID No to register new visitors. However on our current system, the visitor record will be populated based on the previous signed in visitor whenever they entered the same ID No. Hence, by applying Purge Visitor action procedures, user can reuse the same ID No to sign in new visitor.

User must configure the Action Procedures and Schedule Task for this operation to be completed.

Related Software:

xPortalNet IS v1.5.0.125 or higher

Related Hardware:

NIL

System Application:

Visitor Management System

Symptom and Finding:

NIL

Cause:

For first time guide to configure the Action Procedures Purge Visitor in xPortalNet software.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

.

.

Summary 


Step-by-step Guide: 

  • To Configure Action Procedures: 

In these steps, user will be guided to setup the Action Procedures. The Purge Visitor is an action that will delete the existing signed in visitor records.Once this action has been executed, user have to re-enter all visitor information when they want to sign in the same visitor again.


Step 1: Login to xPortalNet Server software. 


Step 2: Open Action Procedures. Go to Server Admin > Action Procedures.


Step 3: The Add Action Procedures window will be shown.

  • Fill in the Code and Description.
  • Then, click Add to add the Action Type.

Add Action Procedures Window
Figure 1: Add Action Procedures Window.


Step 4: The Add Action Type window will be shown.

  • Select Purge Visitor from the Action list.
  • Then, click Next to configure the Purge Visitor Properties.

Add Action Type Window
Figure 2: Add Action Type Window.


Step 5: The Purge Visitor Properties window will be shown.

  • Specify the Period (in days) after which the existing visitor record will be deleted.
    (For this example, after 1 day of the visitor records was created, it will be deleted accordingly)
  • Then, click OK to continue.

Purge Visitor Properties
Figure 3: Purge Visitor Properties.


Step 6: Make sure the settings is correct. Then, click OK to save the changes.
Add Action Procedures Window
Figure 4: Add Action Procedures Window.


Step 7: The following message will be shown. Click OK to continue.
Record Added Message
Figure 5: Record Added Message.


Step 8: You have successfully added the Purge Visitor action procedures.
Purge Visitor Action Procedure Successfully Added
Figure 6: Purge Visitor Action Procedure Successfully Added.

.

.

  • To Configure Schedule Task: 

In these steps, user will be guided to configure the Schedule Task. It will be used to schedule the Purge Visitor when it is to be executed.


Step 1: Login to xPortalNet Server software.


Step 2: Open Schedule Task. Go to Server Admin > Schedule Task.


Step 3: The Add Schedule Task window will be shown.

  • Fill in the Code and Description.
  • This Schedule Task must be enabled in order to execute the Purge Visitor.
  • Then, click Action Procedures.

Add Schedule Task
Figure 7: Add Schedule Task.


Step 4: Select the pre-configured Purge Visitor Action Procedures. Then, click OK.
Select Action Procedures
Figure 8: Select Action Procedures.


Step 5: Click Schedule and the following window will be shown.

  • Configure the Schedule according to the user preferences.
    (For this example, the Schedule Task will execute the Purge Visitor Action Procedures once on 7/13/2018 at 18:00)
  • Then, click OK to save the changes.

Edit Schedule Window
Figure 9: Edit Schedule Window.


Knowledge Base Link

User can choose from 3 Schedule Type which are Once at services startup, Recurring and One time. Further details on Schedule Type, please refer to the following link: How to Configure Schedule Task in xPortalNet Software


Step 6: After user confirm the settings and click OK, the following message will be shown. Click OK to continue.
Record Added Message
Figure 10: Record Added Message. 


Step 7: You have successfully added the Schedule Task.
Schedule Task Setup Successfully Added
Figure 11: Schedule Task Setup Successfully Added.

.

.

  • To Validate the Purge Visitor Action Procedures: 

In these steps, user will be guided on how to validate the Purge Visitor Action Procedures. User can see when the action will be executed from the Latest Event List. 


Step 1: Login to xPortalNet Client software.


Step 2: Open Visitor Still In List tab and Sign In the visitor.

Knowledge Base Link

Users can refer to How to Setup Visitor Management System on xPortalNet Software for the complete steps to SIgn In the visitor.

.

Step 3: Below is an example of signed in visitor records. This visitor is using ID No 102.

Visitor Still In List tab
Figure 12: Visitor Still In List tab.


Visitor Information Window
Figure 13: Visitor Information Window.


Info

The process of purging visitor will be based on the DateOfCreation of the visitor records. 
Visitor records in SQL Database
Figure 14: Visitor records in SQL Database.

Important

  • Visitors whom are signing in / being blocked will not be deleted when the Purge Visitor is executed.
  • Make sure visitor is already signed out / not being blocked before the Purge Visitor is executed.
  • Existing visitor record will not be deleted if its date of creation is older than the day(s) set from Action Procedures.

.

Step 4: Observe the Latest Event List.

  • The following transactions mean the Purge Visitor Action Procedures has started and completed.
  • The execution date and time is according to the Schedule Task settings.

Latest Event List Window
Figure 15: Latest Event List Window.


Step 5: The log of this action can be found from the C:\ProgramData\MicroEngine\xPortalNet v1\Server\ScheduledTaskLogs.
Schedule Task Log File
Figure 16: Schedule Task Log File. 


Step 6: To verify that the visitor record has already been deleted, sign in new visitor by using the same ID No. The previous visitor record is no longer populated into the Visitor Sign In Information
Visitor Sign In Transaction Window
Figure 17: Visitor Sign In Transaction Window.

Document Date

11/07/2018 (Rev 1.0)

PROOF-READ

.

.


.

© MicroEngine Technology Sdn Bhd (535550-U). All rights reserved.