How to Configure IP Address for IP Controllers

Problem (Issue) Statement:

How to configure IP address for IP controller

Description:

A guide to configure IP address for IP controllers.

Related Software:

NA

Related Hardware:

  • XP-M1000i / XP-M1300i / XP- M1300i/IP / XP-M1000i-SE21
  • XP-M2000i / XP-M2300i / XP-M2300i/IP
  • XP-SNET / XP-SNETv4 / XP-SNET/IPC
  • XP-GT3500 / GTR1500
  • XP-GLS100v4 / XP-GLS130v4/ XP-GLS230v4
  • XP-GLS300v4
  • XP- Q1200i / XP-Q1200/IP
  • XP- QNET / XP-QNET/IPC
  • XP-SNET-GAC / XP-GLS-GAC

System Application:

NA

Symptom and Finding:

NA

Cause:

For first time configuration of IP address for IP controllers.

Solution:

Summary

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Step-by-step Guide:

  • To perform ColdStart after first power up of the IP controllers:

Note

Users may refer to the sticker manuals on the enclosure box for steps on how to perform ColdStart as it may differ slightly for different controller models.

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  • To perform pre-configuration settings on the network connection:

Note

Users may refer to How to Pre-configure Network Connection for IP Controllers to complete the process. 

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  • To configure the IP address via Web Diagnostics:

Step 1: Open IE browser (Internet Explorer) and type the default IP address in the address box.

Default IP Address for IP Controllers

  • XP-M1000i / XP-M1300i / XP- M1300i/IP – 192.168.1.10
  • XP-M1000i-SE21 - 192.168.1.21
  • XP-M2000i / XP-M2300i / XP-M2300i/IP – 192.168.1.10
  • XP-SNET / XP-SNETv4 / XP-SNET/IPC – 192.168.1.210
  • XP-GT3500 / GTR1500 – 192.168.1.20
  • XP-GLS100v4 / XP-GLS130v4/ XP-GLS230v4– 192.168.1.10
  • XP-GLS 300 – 192.168.1.210
  • XP-GLS5000 – 192.168.1.210
  • XP- Q1200i / XP-Q1200/IP - 192.168.1.10
  • XP- QNET / XP-QNET/IPC - 192.168.1.210
  • XP-SNET-GAC / XP-GLS-GAC - 192.168.1.220

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Step 2: The Windows Security dialog box will be shown. Enter the User name and Password and click OK to continue.

Note

Default User Name: admin

Password: password10

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The Windows Security Dialog Box
Figure 1: The Windows Security Dialog Box


Step 3 : Once the login is successful, a home window will be shown:
The Web Diagnostic Home Window for XP-M1000i Controller
Figure 2: The Web Diagnostics Home Window for XP-M1000i Controller


Step 3: Go to Configuration > Network. The Network Setting window will be shown. Configure the Controller's IP address, Subnet Mask, Gateway and Server PC's IP address settings. Click Save Setting to save the changes made.
The Network Setting Window .
Figure 3: The Network Settings Window


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Note

  • Once the settings are saved, the Web Diagnostics is only accessible via the newly changed controller IP address.
  • The controller and Server PC's IP addresses are required to be configured with static IP addresses.
  • The communication port between Server and controller is of ÚDP type with default port number: 6268.
  • Ensure Server and controller's IP addresses are unique IP addresses in the network and that both IP addresses are not already occupied by another device / controller.
  • Ensure that the setting for Enhanced Network Encryption (AES 128) is configured to be the same as the controller setting in the xPortalNet software. If the setting on Web Diagnostic does not match with the setting in the software, the controller will also be shown as "Down"
Common Issues:

Often times after re-connecting to the network, the controller status may be shown as "Down" due to the controller and Server PC's IP addresses are automatically assigned as dynamic IP addresses (DHCP) in the network.

With dynamic IP address, a device can have different IP address every time it re-connects to the network or when the network detects that the IP address is already occupied by another device / computer.

So if the user found that the controller status is shown as "Down"; or the status is shown as "Up" and "Down" intermittently, check and ensure that both controller and Server PC's IP addresses are configured as static IP addresses.

Date Documentation:

24/6/2023 (Rev 1.1)

PROOF-READ

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