Error Message of "SQL Server Does Not Exist or Access Denied" is Shown When Users Attempt to Launch xPortalNet Server (Solution 1)

Problem (Issue) Statement:

Why use is unable to login to xPortalNet Server and SQL Server Does Not Exist Or Access Denied Error Message is Shown

Description:

User is unable to login to xPortalNet Server application software due to “[DBNETLIB] [Connection Open(Connect0).] SQL Server does not exist or access denied.” error message. 

Related Software:

  • Microsoft SQL Server and xPortalNet software.

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

When user try to launch and login to xPortalNet Server application, the error message as shown below will pop out.

Figure 1: SQL Server Does Not Exist or Access Denied Error Message

Cause:

This is caused by the MSSQL Server service not running.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

  • To manually restart the MSSQL Server service in Task Manager.


Step-by-step Guide:

  • To manually restart the MSSQL Server service in Task Manager:

Step 1: Open Task Manager.

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Step 2: Go to Services tab and look for MSSQL$MSSQLSERVER2014.

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Step 3: Check on the Status column.

Figure 2: MSSQL$MSSQLSERVER2014 Service

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Step 4: If the Status is Stopped, right click and start the service.

Figure 3: Starting the MSSQL$MSSQLSERVER2014 Service

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Step 5: Make sure the SQL Server Status is Running.

Figure 4: Ensure that the MSSQL$MSSQLSERVER2014 Service is Running Before Running xPortalNet Service

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Step 6: Launch xPortalNet Comm Service Controller and start the service.

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Step 7: Right click on the xPortalNet Service icon at the system tray and click on Check Service Info.
Right-clicking xPortalNet Service Icon and Selecting Check Service Info
Figure 5: Right-clicking xPortalNet Service Icon and Clicking Check Service Info

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Step 8: Check and ensure that the DB Connection is shown as Up.
DB Connection Shown as Up
Figure 6: DB Connection Shown as Up

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Step 9: Launch and login to xPortalNet Server.

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Step 10: Launch and login to xPortalNet Client.

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Date Documentation:

12/7/2018 (Rev 1.0)

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