How to Restore xPortalNet Database (with .bak file) to new Server's PC

Problem (Issue) Statement:

How to restore xPortalNet database (with .bak file) to new Server's PC

Description:

A guide to restore xPortalNet database from .bak file format.

Related Software:

Related Hardware:

NA

System Application:

xPortalNet Standard Software

Symptom and Finding:

NA

Cause:

For first time restore of xPortalNet database from .bak file format.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Knowledge Base Link

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Summary

  • To stop xPortalNet Services.

  • To restore backed-up xPortalNet database files to SQL Server.


Step-by-step Guide:

  • Stopped xPotalNet Services:

Step 1: To close xPortalNet Server & Client if any of the software instances are still running.


Step 2: Right-click the xPortalNet Service icon, click Stop. Wait for the pop-up message indicating that the xPortalNet Service has been stopped.
Right-click xPortalNet Service Icon and Click Stop
Figure 1: Right-click xPortalNet Service Icon and Click Stop


xPortalNet Service Pop-up Message
Figure 2: xPortalNet Service Stopped Pop-up Message


  • To restore backed-up xPortalNet database files to SQL Server:

Step 1: Open the SQL Server Management Studio software application.
Open SQL Server Management Studio Software
Figure 3: Open the SQL Server Management Studio Software


Step 2: The following window will be shown. Click Connect.
Connect to Server Window from SQL Server Management Studio Software
Figure 4: Connect to Server Window from SQL Server Management Studio Software


Note

  • If Authentication under SQL Server Authentication, please key-in User name and password before click Connect.
  • The User Name and Password is created during Microsoft SQL Server 2012 installation. Please refer How to Install Microsoft SQL Server 2012 for the installation step.



Step 3: Expand the Database folder to find the dropdown list.
Expanding the Database Folder
Figure 5: Expanding the Database Folder


Step 4: The 'XPNDB' and 'XPNTR' folder will be shown.
XPNDB and XPNTR Folder under Database Folder
Figure 6: The XPNDB and XPNTR Folder under Database Folder

Note

The list of XPNTR folder may be slightly different for different users. The transaction database is structured based on the monthly transactions pulled up by the software.



Step 5: To restore the database, right click the 'XPNDB' folder > Tasks > Restore > Database.
Restore XPNDB Folder
Figure 7: To Restore XPNDB Folder


Step 6: The Restore Database- XPNDB window will be shown. Ensure that the To database: field is selected as 'XPNDB'. Under the 'Source for restore' section, select From device then browse and locate the backup database file.
Restore Database - XPNDB Window
Figure 8: Restore Database – XPNDB Window


Step 7: Please ensure that Back up to 'Disk' checkbox is checked and click Add for new backup destination folder location.
Check Back Up to Disk Checkbox for new Backup Destination Folder Location .
Figure 9: Checking Back Up to Disk for new Backup Destination Folder Location


Step 8: Click Add to specify the backup database location for the database restore operation.
Specify Backup Window
Figure 10: Clicking Add to specify new Backup Database Location


Step 9: The Locate Backup File window will be shown. Select the backup file and click OK.
Locate Backup File Window
Figure 11: Selecting the Backup File


Step 10: Confirm the backup file location and click OK to continue.
Confirming Backup File Location
Figure 12: Confirming the Backup File Location


Step 11: Check the database to restore and at the top left of the window, select Options page.
Checking Restore Checkbox in Restore Database - XPNDB Window
Figure 13: Checking the Restore checkbox in Restore Database – XPNDB Window


Step 12: Under the Restore options section, check Overwrite the existing database (WITH REPLACE) checkbox and click OK to start the database restore process.
Checking Overwrite the Existing Database Option in Restore Database - XPNDB Window .
Figure 14: Checking Overwrite the Existing Database Option


Step 13: Once the restore process is completed, the following window will be shown. Click OK.
Database Restore Completed Message Window
Figure 15: The Database Restore Completed Message Window

Date Documentation:

9/4/2018 (Rev 1.0)

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