Why are Users Unable to Delete Door Accessibility Code

Why are Users Unable to Delete Door Accessibility Code

Problem (Issue) Statement:

Why are users unable to delete Door Accessibility Code

Description:

Users are unable to delete Door Accessibility Code, with the software showing the following error message:


Figure 1: Door Accessibility is Assigned to 1 Card Holders, Therefore This Records Cannot Be Deleted Error Message

Related Software:

  • xPortalNet Lite

  • xPortalNet Standard

  • xPortalNet PS

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

When users attempt to delete the Door Accessibility Code, the following error message is shown:

Door Accessibility is Assigned to 1 Card Holders, Therefore This Records Cannot Be Deleted Error Message
Door Accessibility is Assigned to 1 Card Holders, Therefore This Records Cannot Be Deleted Error Message


Figure 2: Door Accessibility is Assigned to 1 Card Holders, Therefore This Records Cannot Be Deleted Error Message

Cause:

The Door Accessibility Code is still assigned to card holders. Therefore the software does not permit the deletion of the affected Door Accessibility Code.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

  • To un-assign the affected Door Accessibility Code from the card holder(s).

Step-by-step Guide:

  • To un-assign the affected Door Accessibility Code from the card holder(s):

Step 1: Ensure that xPortalNet Services is running.

 

Step 2: Go to xPortalNet Client > Data Setup > Access Data Setting > Staff Record and click Get Now! to continue.


Figure 3: Staff Detail List Window

 

Step 3: The Staff Detail Setup window will be shown. Find and select the card holder(s) that are still assigned with the affected Door Accessibility Code.


Figure 4: The Staff Detail Setup Window Showing the Card Holder that is Still Assigned with the Card Accessibility Code

 

Step 4: Assign another Door Accessibility Code to the card holder in order to be able to delete it. Users can assign it with either default accessibility codes of #0000 (no access) or #0001 (free access)

 

Step 5: Go back to Door Accessibility Setup window and delete the Door Accessibility Code again. The following message will be shown by the software to indicate that the Door Accessibility Code has been deleted successfully.


Figure 5: Record Deleted Message

Common Issues:

NIL

Porting Date:

27/11/2018 (Rev 1.0)

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