Why are Users Unable to Delete Door Accessibility Group as the xPortalNet Software Showed "This Record Cannot be Deleted" Error Message

Problem (Issue) Statement:

Why are user unable to delete door accessibility group as xPortalNet software showed "This record cannot be deleted" error message

Description:

When users attempt to delete door accessibility group in xPortalNet software, the software prompted an error message, and the door accessibility is not able to be deleted.

Related Software:

  • xPortalNet v1.5
  • xPortalNet HS v1.8

Related Hardware:

NIL

System Application:

  • Door Access System
  • Turnstile Access System
  • Vehicle Access System

Symptom and Finding:

When user tried to delete Door Accessibility Access No 0002 at Door Accessibility Schedule, the following error message is shown to indicate that the Door Accessibility Group [002] cannot be deleted because there is Card Holder assigned to the Door Accessibility [002].
 
Figure 1: Door Accessibility #0002 is Assigned to Card Holders, Therefore This Record Cannot be Deleted Error Message

Cause:

  • There are Staffs that are still assigned to the door accessibility group that user tried to delete. 

Solution:







Summary:

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Note

Users can choose to EITHER Method 1 or Method 2 to complete the process.

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Step-by-step Guide:

  • To find staffs who are assigned with Door Accessibility #0002:

Step 1: Go to xPortalNet ClientData Setup Access Data Setting Staff Records
Staff Recors Button in Access Data Setting Menu
Figure 1: Staff Records Button in Access Data Setting Menu

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Step 2: The Staff Detail List window will be shown, Un-tick Any Door Access > click the drop-down arrow for the Door Access field > select Door Accessibility to be deleted.
Staff Detail List Window 
Figure 2: Staff Detail List Window

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Step 3: Double confirm Door Access [002] selected is the door accessibility to be deleted. Click Get Now!
 
Figure 3: Double Confirming the Door Accessibility to be Deleted and Click Get Now!

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Step 4: The Staff Detail Setup window will then be shown and listed all staff records assigned with the Door Access #0002
 
Figure 4: Staff Detail Setup Window Showing All Staffs Assigned with Door Access #0002

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In this example, there are a total of 3 card users assigned with the door accessibility #0002.

Figure 5: Three Card Users Assigned to the Door Accessibility #0002

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  • Method 1: To assign related staff to another door accessibility group (one by one):

Step 1: Continue the filter staff record list and select each of the staff and click Modify.
Selectign Each Staff and Click Modify 
Figure 6: Selecting Each Staff and Click Modify

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Step 2: The Edit Staff Detail window for the selected card user will be shown as below. Click Door Accessibility Tab.
Door Accessibility Tab in Edit Staff Detail Window 
Figure 7: Door Accessibility Tab in Edit Staff Detail Window

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Step 3: Under Door Accessibility Tab, select Use Predefined Setting to choose another Door Accessibility Group
Door Accessibility Tab 
Figure 8: Door Accessibility Tab

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Step 4: Assign a new Door Accessibility for this card user and click OK to continue.
Assigning a Different Door Accessibility to the Card User
Figure 9: Assigning A Different Door Accessibility to the Card User


Step 5: The following message window will be shown to indicate Record Updated. Click OK to continue. 
Record Updated Window 
Figure 10: Record Updated Window

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Step 6: Back at the Staff Detail Setup window, notice that the record has decreased to 2 users from 3 users earlier as shown in figure 6. The card user that we previously assigned to a different Door Access number has been removed from this list. 
 
Figure 11: Staff Detail Setup Updated with Remaining Card User Still Assigned with Door Access #0002

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Step 7: Repeat the step 1 to step 5 to re-assign the remaining card users to a different Door Access number.

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Step 8: When all related card users are re-assigned to a different Door Access number, user can now delete the Door Accessibility Group [002].
 
Figure 12: Staff Detail Setup Window Showing No Other Card User Assigned with Door Access #0002

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  • Method 2: To assign related staffs to another door accessibility group (by group):

Step 1: At the Staff Detail Setup showing all card users assigned with Door Access #0002, click on Batch Update Door Access
Batch Update Door Access on Staff Detail Setup Window 
Figure 13: Batch Update Door Access on Staff Detail Setup Window

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Step 2: The Batch Update Staff Record window will then be shown. In the Old Door Access field, select "0002". 
 
Figure 14: Selecting "0002" in Old Door Access Field 

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Step 3: In the New Door Access field, choose any new Door Accessibility Group to assign this new Door Accessibility for these card users.
Selecting the New Door Access Group 
Figure 15: Selecting the New Door Access Group

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Step 4: Ensure the Door Accessibility Group for Old Door Access and New Door Access is correct. Click OK to continue.
Clicking OK to Continue 
Figure 16: Clicking OK to Continue

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Step 5: The following message window will be shown to indicate Total Record Affected, click OK to continue.
Total Records Affected Window 
Figure 17: Total Records Affected Window

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Step 6: The following message window will be shown to indicate Record Updated, click OK to continue.
Record Updated Window 
Figure 18: Record Updated Window

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  • To delete the Door Accessibility Group required:

Step 1: Users can now delete the Door Accessibility Group.

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Step 2: Go to Data Setup Access Data Setting Door Accessibility Schedule.
Door Accessibility Schedule Button Under Access Data Setting Menu 
Figure 19: Door Accessibility Schedule Button Under Access Data Setting Menu

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Step 3: The Door Accessibility Setup window will be shown.
Door Accessibility Setup Window
Figure 20: Door Accessibility Setup Window 

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Step 4: Select Door Accessibility [0002] to be deleted and click Delete.
Selecting the Door Accessibility and Click Delete 
Figure 21: Selecting the Door Accessibility and Click Delete

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Step 5: The following message window will be shown to prompt users to confirm to delete. Click Yes to continue.
Confirm Delete Window 
Figure 22: Confirm Delete Window

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Step 6: The following message window will be shown to indicate that the selected Door Accessibility Group [002] is deleted. Click OK to complete process.
Record Deleted Window 
Figure 23: Record Deleted Window

Common Issue

NIL

Date Documentation:

30/3/2020 (Rev 2.0)

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