How to Configure xPortalNet Software to Prevent Door Access During Holidays

How to Configure xPortalNet Software to Prevent Door Access During Holidays

Problem (Issue) Statement:

How to configure xPortalNet software to prevent door access during holidays

Description:

Users can configure the door to not be accessible during the holidays. This can be done by configuring the Holiday Set, the Time Zone, and Door Accessibility Setup. Then, the Door Access Code can be assigned to the staff profile accordingly.

Related Software:

  • xPortalNet Lite

  • xPortalNet Standard

  • xPortalNet PS

Related Hardware:

All Controller Models

System Application:

NIL

Symptom and Finding:

NIL

Cause:

For first time guide to configure xPortalNet software to prevent door access during holidays

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

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Step-by-step Guide:

  • To configure the Holiday dates:

Step 1: Ensure that the xPortalNet Services is running.

 

Step 2: Go to xPortalNet Client > Data Setup > Access Data Setting > Holiday Set > All Holiday Dates.

 

Step 3: The Holiday Setting window will be shown. Click Add.


Figure 1: Holiday Setting Window

 

Step 4: The Add Holiday window will then be shown. Set the holiday date correctly by giving it a reference name (code) and description. Click OK to save the changes.


Figure 2: Add Holiday Window

 

Step 5: Repeat Steps 2 to 4 to add the remainder of the holiday dates.

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  • To assign the No Access Time Zone to Door Accessibility:

Step 1: Set a new Time Zone which contains the normal hours where card users are permitted to gain access to the doors during the weekday, but selecting Time Set "000" for Holiday.

Knowledge Base Link

Users can refer to How to Configure Time Zone Settings in xPortalNet Software to complete the procedures to set Time Zone configurations.

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Step 2: To assign the pre-configured Time Zone in Step 1, go to xPortalNet Client > Data Setup > Access Data Setting > Door Accessibility Schedule > Add.


Step 3: The Add Door Accessibility Window will then be shown. Select the desired door to apply the pre-set Time Zone in Step 1, and choose assign the pre-set Time Zone accordingly. Click OK to save the changes.


Figure 3: Add Door Accessibility Window

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  • To assign the Holiday Set and Door Accessibility to staff:

Step 1: Go to xPortalNet Client > Data Setup > Access Data Setting > Staff Records and click Get Now! to continue.

 

Step 2: At the Staff Detail Setup window, users can choose whether to add a new staff or to modify existing staffs to assign with the Door Accessibility.

 

Step 3: At the Add Staff Detail or Edit Staff Detail window, click "Default" button for Holiday Set field.


Figure 4: Add Staff Detail Window

 

Step 4: The Holiday Set window will then be shown. Select the pre-configured Holiday Set in section 1. Click OK to save the changes.


Figure 5: Holiday Set Window

 

Step 5: Back at the Add Staff Detail or Edit Staff Detail window, click Door Accessibility tab. At the Use Predefined Settings field, select the pre-configured Door Accessibility at section 2. Click OK to save the changes.


Figure 6: Door Accessibility Tab

 

Step 6: Back at Staff Detail Setup, users will be able to see the added / edited staff records with the correct details.


Figure 7: Staff Detail Setup Showing the Correct Settings

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  • To send Door Settings to the relevant controllers:

Step 1: Go to xPortalNet Client > Device Comm > Send Door Settings.

 

Step 2: The Send Door Controller Settings window will be shown. Select the relevant controller(s) and click Holiday Dates.


Figure 8: Send Door Controller Settings Window

 

Step 3: Go to xPortalNet Client > Device Comm > Send Staff Settings.

 

Step 4: The Send Card Settings window will then be shown. Select the relevant controller(s) and click Send All.


Figure 9: Send Card Settings Window

 

Step 5: Ensure that the Delivery Report for both processes in Step 2 and Step 4 does not yield any errors.

 

Step 6: Users can then attempt to flash a valid access card to the controller during the holidays to verify that the transaction recorded is "Wrong Time Zone" transaction.


Figure 10: Latest Event List Showing the Wrong Time Zone Transaction

Common Issues:

NIL

Porting Date:

30/11/2018 (Rev 1.0)

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