A Majority of Registered Card User Suddenly Failed to Gain Door Access After System User Downloaded New Card Data to the Controller

Problem (Issue) Statement:

A majority of registered card user suddenly failed to gain door access after system user downloaded new card data to the controller.

Description:

User complained that a majority of the registered card users suddenly were unable to gain door access after system user downloaded new card data to the controller.

Related Software:

  • xPortalNet v1.5.0.123

Related Hardware:

  • XP- M2000i v6.17
  • XP- M1000iv2 v5.40
  • XP-SNET v3.48
  • Plato Reader C80s v7.00

System Application:

  • Door Access System
  • Lift Masking Access System
  • Vehicle Access System
  • Turnstile Access System

Symptom and Finding:

When user flashed card on the Plato reader, the reader responded with 4 beeps and software logged "Unknown Card Number" transaction.

xPortalNet is able to show the card user's name but the "Unknown Card Number" transaction is logged in the Latest Event Transaction.

Cause:

Upon further investigation, it is discovered that the software logged a "Clear Card DB transaction before the problem occurred.

The system user selected an incorrect method to install new cards to the controller, and along the process of doing so, the system user has accidentally cleared the existing card database in the controller.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Note

This article will guide system users to send / download card data to controller via the Device Comm with several methods as shown below.

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Summary:

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Step-by-step Guide:

  • Select all cards data with selective download to controllers:

Warning!

This action will affect system operation as the software will send "Clear Card Database" command before installing all selective card users.



Step 1: Go to xPortalNet Client > Device Comm > Send Staff Setting.
Send Staff Setting Button in Device Comm Icon
Figure 1: Send Staff Setting Button in Device Comm Icon


Step 2: The Send Card Setting window will be shown. Select the controller(s) to send the card settings, tick the All Card checkbox and Selective Download checkbox. Click Install Card.

Figure 2: Send Card Settings Window


Note

When the Selective Download checkbox is ticked, each controller will only be sent card data that have the right to access the controller's door.



Tip

Starting from /wiki/spaces/SRN/pages/203882516and above, when All Card checkbox is ticked, the software will prompt a message window as below to indicate that this action will trigger a clear card database command to the controller. Click Yes to confirm, or click No to skip Clear Card DB command.




Figure 3: Message Window to Confirm Clear Card Database Command


Step 3: The Delivery Report window will be shown to notify users of the card and data sending progress.


Step 4: Note that if users clicked Yes in the previous window, the first command from the software is to send a Clear Card DB command to the controller before installing the card data.
Delivery Report Window with Clear Card DB as the First Command
Figure 4: Delivery Report Window with the Clear Card DB as the First Command
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  • Select all cards data without selective download to controllers:

Warning!

This action will affect system operation as the software will send "Clear Card Database" command before installing all selective card users.



Step 1: Go to xPortalNet Client > Device Comm > Send Staff Setting.
Send Staff Setting Button in Device Comm Icon
Figure 5: Send Staff Setting Button in Device Comm Icon


Step 2: The Send Card Setting window will be shown. Select the controller(s) to send the card settings, tick the All Card checkbox but leave the Selective Download checkbox unticked. Click Install Card.

Send Card Settings Window
Figure 6: Send Card Settings Window


Note

When the Selective Download checkbox is unticked, the software will send all card data to the selected controller(s); regardless of whether the sent card user has access to the controller's door or not.



Step 3: The Delivery Report window will be shown to notify users of the card and data sending progress.

Step 4: Note that if users clicked Yes in the previous window, the first command from the software is to send a Clear Card DB command to the controller before installing the card data.
Delivery Report Window Showing Clear Finger Print Template DB and Clear Card DB Command from Software
Figure 7: Delivery Report Window with the Clear Card DB as the First Command
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  • Select specific card data with selective download to controllers:

Note

This action WILL NOT affect system operations when installing specified card holder selection range with selective download.



Step 1: Go to xPortalNet Client > Device Comm > Send Staff Setting.
Send Staff Setting Button in Device Comm Icon
Figure 8: Send Staff Setting Button in Device Comm Icon


Step 2: The Send Card Setting window will be shown. Select the controller(s) to send the card settings, untick the All Card checkbox but tick Selective Download checkbox. Click Install Card.

Send Card Setting Window
Figure 9: Send Card Settings Window


Note

When the Selective Download checkbox is ticked, each controller will only be sent card data that have the right to access the controller's door.



Step 3: The Delivery Report window will be shown to notify users of the card and data sending progress.


Step 4: Note that the software did not send a Clear Card DB command to the controller before installing the card data.
Delivery Report Window Without the Clear Card DB Command
Figure 10: Delivery Report Window Without the Clear Card DB Command
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  • Select specify card data without selective download to controllers

Note

This action WILL NOT affect system operations when installing specified card holder selection range with selective download.




Step 1: Go to xPortalNet Client > Device Comm > Send Staff Setting.
Send Staff Setting Button in Device Comm Icon
Figure 11: Send Staff Setting Button in Device Comm Icon


Step 2: The Send Card Setting window will be shown. Select the controller(s) to send the card settings, untick both All Card and Selective Download checkboxes. Click Install Card.

Send Card Settings Window
Figure 12: Send Card Settings Window


Step 3: The Delivery Report window will be shown to notify users of the card and data sending progress.


Step 4: Note that the software did not send a Clear Card DB command to the controller before installing the card data.
Delivery Report Window Without the Clear Card DB Command
Figure 13: Delivery Report Window Without the Clear Card Database Command

Date Documentation:

25/7/2018 (Rev 1.0)

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