How to Configure the Email Notification in xPortalNet Software

How to Configure the Email Notification in xPortalNet Software

Problem (Issue) Statement:

How to configure the email notification in xPortalNet software

Description:

A guide to configure email notification feature to allow software to send out email to the specified user upon the triggering of certain pre-defined event.

Related Software:

  • xPortalNet v1.5.0.161

Related Hardware:

NA

System Application:

  • Email Notification

Symptom and Finding:

NA

Cause:

For first time configuration on email notification feature to allow software to send out email to the specified user upon the triggering of certain pre-defined event.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary



Note

To perform steps below accordingly, please ensure network connection stable.


Step-by-step Guide:

  • To configure Email Notification:

Step 1: Ensure that xPortalNet Services is running.


Step 2: Go to xPortalNet Server > Server Admin > System Properties > Modify.


Step 3: The Edit System Properties window will be shown. Click Email & SMS tab. Fill up all information accordingly at Email Notification section. Click OK to continue.


Figure 1: Email and SMS Tab in Edit System Properties Window





The following screenshot shows an example of an email notification setup. This setting can be used for Gmail account.

Figure 2: Example of Email Notification Setup



Tips

  • For Gmail users, the access for less secure apps must be allowed. Users can refer to KB- ID-000105 How to turn on access for less secure apps in Gmail? for the complete steps to perform the action.

  • Also attached is A List of SMTP and POP3 Server for reference to help users to complete the configuration setup.





Step 4: Click Test Sending Email to test and ensure that the configuration on Email Notification are done correctly.


Step 5: If the configuration is done correctly, the software will prompt the following message window to indicate that the "Email was sent successfully."


Figure 3: Email was Sent Successfully Window


Step 6: Sign into the email account registered at Email Notification configuration settings and verify that the email inbox received the email from xPortalNet, as shown below.


Figure 4: Email Notification Received from xPortalNet Comm Service


Step 7: Click OK and Close to exit from System Properties window.
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  • To configure Notify User:

Step 1: Go to xPortalNet Server > Server Admin > Notify User.


Figure 5: Notification Setup Window


Step 2: Click Add to add a new notification. The Add Notification Window will be shown. Fill up all information accordingly. Click OK to save the changes.


Figure 6: Add Notification Window


Step 3: The following message window will be shown to indicate that the Record is Updated. Click OK to continue.


Figure 7: Record Updated Window


Step 4: Click Close to exit the Notification Setup window.




  • To verify that the Email Notification settings are configured correctly:

Step 1: To trigger the specified event transaction for testing purposes.


Step 2: At the Latest Event List, ensure that the transaction of Send Email OK is logged as shown below.


Figure 8: Send Email OK Transaction Recorded in Latest Event List


Step 3: Check in the email inbox to confirm receiving the Email Notification for the triggering of the event transaction as shown below.


Figure 9: Email Inbox Showing the Email Notification

Date Documentation:

28/6/2018 (Rev 1.0)

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