Why xPortalNet Software Failed to Send the Test Email for Email Notification Feature

Problem (Issue) Statement:Why xPortalNet software failed to send the test email for Email Notification feature
Description:

Users failed to send the Test Sending Email in order to test the setup for Email Notification feature.

Related Software:
  • xPortalNet
Related Hardware:NIL
System Application:NIL
Symptom and Finding:

After clicking Test Sending Email, the xPortalNet software prompted the following error messages:
Email Could Not be Sent Error Message
Figure 1: Email could not be sent. Failure sending mail Error Message


Error Test Sending Email Message 2
Figure 2: Email could not be sent. The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Authentication required Error Message

Cause:
  • The email notification is turned off
  • The email address / password provided is incorrect
  • The SMTP Server Name and SMTP Port are configured incorrectly
Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Step 1: Go to xPortalNet Server > Server Admin > System Properties > Modify. The Edit System Properties window will be shown. Click Email & SMS tab.
Edit System Properties Window
Figure 3: Edit System Properties Window

Step 2: The Email & SMS tab will then be shown. At the Email Notification field, click on the drop-down dialog box and select "On". Click OK to save the changes.

Figure 4: Email & SMS Window


Step 3: The software will then prompt the following message windows to indicate that the record is updated and to remind users to download the settings to the respective controllers.
Record Updated Window
Figure 5: Record Updated Window


Message to Remind Users to Download Settings to Controller
Figure 6: Message to Remind Users to Please go to xPortalNet Client software to download the settings (Device Comm → Send Door Controller Settings → Door Parameters)


Step 4: Back at the System Properties window, click Close to exit from the window.

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  • To ensure that users entered the correct email address and password:

Step 1: Go to xPortalNet Server > System Properties > Modify > Email & SMS tab. The Email & SMS window will be shown. Ensure that the information entered under Account Name and Password are valid. 

Figure 7: Account Name and Password Field under Email & SMS Tab 


Step 2: Go to xPortalNet Server > Server Admin > Notify User > Add. The Add Notification window will be shown. Ensure that the correct email address is entered at the Email Address field. Click OK to save the changes.
Add Notification Window
Figure 8: Add Notification Window


Step 2: Back at the Notification Setup window, click Close to exit the window.

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  • To configure the SMTP Server Name and SMTP Port correctly:

Step 1: Go to xPortalNet Server > System Properties > Modify > Email & SMS tab. The Email & SMS window will be shown. Ensure that the information entered in the SMTP Server Name and SMTP Port fields are correct.

Figure 9: SMTP Server Name and SMTP Port Field in Email & SMS Tab 

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Step 2: Click here for more information regarding SMTP Server Name and SMTP Port.

Common Issues:NIL
Porting Date:1/3/2019

PROOF-READ

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