Why Certain Existing Card Users are Suddenly Unable to Access Doors and Software Transaction Log Shows "Unknown Card Number" Transaction

Problem (Issue) Statement:

Why certain existing card users are suddenly unable to access doors and software transaction log shows "Unknown Card Number" transaction

Description:

Why certain existing card users are suddenly unable to access doors and software transaction log shows "Unknown Card Number" transaction?

Related Software:

Related Hardware:

  • XP-GLS100v4

System Application:

  • Door Access System

Symptom and Finding:

A complaint was lodged where certain existing card users are suddenly unable to access some of the doors in the facility. Note that these doors are previously accessible by the affected card users.


The Audit Trail report shows that the system users did not modify any of the door accessibility, or delete any of the card users. In Staff Record, the affected card users are still assigned with the same door access level that grants access to the affected doors.


An important point to note is that the affected controllers usually have large card user databases.

Cause:

This situation happened to some of the controller models with the new flash chip (SST26F032B SPI Flash) and a firmware bug affecting proper handling of card memory. The bug only occurs when new card data are indexed into pages in scenarios where the last 2 digits of the card number are the same, and that the card page is full (exceeded 128 card data entries per page). In the event when the page is full, and when users issue 'add new card' command, this action will clear the page and controller will subsequently store the new card only due to the bug. This therefore results in card data being lost and the 'Unknown Card Number' transaction will be logged when existing card users flashed the valid card.


Affected controller models with flash chip SST26F032B are shown as below:

  1. GLS-XP100v4
  2. GLS-XP130v4
  3. GLS-XP230v4
  4. XP-M2000i
  5. XP-M1000iv2
  6. XP-GT3500L/ABL
  7. XP-GT1500L/ABL

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary


Step by Step:

  • To verify if it is the card memory issue:

Step 1: Initialize a fresh database for the software and connect the software with the respective controller model (affected by the missing card user issue when retrieving card data from controller).


Step 2: Add 150 card users with same last 2 digits card number (xxxxxx00) via Staff Record and send all card data to connected controller.


Step 3: Retrieve card data from the controller to verify that all 150 card data are installed successfully at the controller.


Step 4: Add a new card user with same last 2 digits card number (1xxxxx00) via Staff Record and send the card data to the same controller.


Step 5: Retrieve card data from the controller again. Under normal operation behaviour, the card data retrieved from controller should be 151 card records. In this case, however, software is only able to recover the newly installed card data (1xxxxx00).


  • To update a new firmware via Remote Update Firmware (xPortalNet) to fix the firmware bug after verifying that it is the card memory issue:

Step 1: For xPortalNet software, go to xPortalNet Server > Utilities.

Utilities Icon
Figure 1: Utilities icon

Step 2: The Remote Update Firmware window will be shown as below. Select the affected controller to perform the remote update firmware. Next, click to select the new firmware version. Click Start to begin the update process.
Remote Update Firmware Window
Figure 2: Remote Update Firmware window


Step 3: Wait for the update process to complete. Click OK to continue.


Step 4: The controller will automatically reset itself and the updated firmware will take effect.




  • To update a new firmware via Remote Update Firmware (xPortal3000) to fix the firmware bug after verifying that it is the card memory issue:

Step 1: For xPortal3000 software, go to xPortal3000 Client > Update Firmware:
Update Firmware
Figure 3: Update Firmware icon


Step 2: The Remote Update Firmware window will be shown as below. Select the affected controller to perform the remote update firmware. Next, click to select the new firmware version. Click Start to begin the update process.
Remote Update Firmware Window
Figure 4: Remote Update Firmware Window


Step 3: Wait for the update process to complete. Click OK to continue.


Step 4: The controller will automatically reset itself and the updated firmware will take effect.


Date Documentation:

25/5/2018 (Rev 1.0)

PROOF-READ

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