Why xPortalNet Service Showed "Test Database Connection" Error Message after Running the xPortalNet Services

Problem (Issue) Statement:

Why xPortalNet Service showed "Test Database Connection" error message after running the xPortalNet Services?

Description:

When run the xPortalNet Services, the xPortalNet Comm Service icon showed the "Test Database Connection" error message.

Related Software:

  • xPortalNet Standard v1.5
  • xPortalNet Lite v1.5
  • xPortalNet PS v1.5
  • xPortalNet HS v1.8

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

After running the xPortalNet Services, the xPortalNet Comm Service icon showed the "Test Database Connection" error message to indicate that the [DBNETLID][Connection Open (Connect ()).]SQL Server does not exist or access denied as below.
Test Database Connection Error Message
Figure 1: Test Database Connection Error Message


Upon clicking on the Check Service Info button, it was discovered that the DB Connection was Down and DB Connection Error indicated that Database connection fail (Error: [DBNETLID][Connection Open (Connect ()).]SQL Server does not exist or access denied.). Make sure the SQL Server is started and settings are correct as below.
About Window from Check Service Info
Figure 2: About Window from Check Service Info


Upon closer inspection in the path C:\ProgramData\MicroEngine\xPortalNet v1\Server it was discovered that the _VMSERR txt file size kept growing and logging the same repeated error message as shown below.
_VMSERR File
Figure 3: _VMSERR File


Repeated Error Message
Figure 4: Repeated Error Message

Cause:

This issue is caused by the SQL instance name not configured as the same between SQL Server and XPNDB Setting .cfg file.
SQL Instance Name in Microsoft SQL Server Management Studio Software
Figure 5: SQL Instance Name in Microsoft SQL Server Management Studio Software


SQL Instance Name in XPNDB Setting .cfg File
Figure 6: SQL Instance Name in XPNDB Setting .cfg File

Solution:

Summary:

  • To correct XPNDB Setting.cfg


Step-by-step Guide:

  • To correct XPNDB Setting.cfg:

Step 1: Stop xPortalNet Services.
xPortalnet Comm Service Stopped Message
Figure 7: xPortalNet Comm Service Stopped Message


Step 2: Go to C:\ProgramData\MicroEngine\xPortalNet v1\Server\Database


Step 3: Open XPNDBSetting.cfg file. Correct the Data Source and ServerName fields according to the SQL Instance name obtained from Microsoft SQL Server Management Studio software.
XPNDBSetting.cfg File
Figure 8: XPNDBSetting.cfg File


Tips

Always check the Microsoft SQL Server Management Studio for the correct SQL Instance Name, which will be listed in the Object Explorer window.




Step 4: After correcting the XPNDB.cfg file and saving the changes, restart the xPortalNet Comm Services to verify that the software is able to access the database.

Common Issue

  • Users commonly did not follow the proper way to restore a database and typically will result in Database Connection Fail error message.
  • Upon changing workstation name, it sometimes will also result in the Database Connection Fail error message.

Date Documentation:

1/11/2018 (Rev 1.0)

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