Generated Daily Attendance Report Shows All Staffs Attendance Summary as "Absent"

Problem (Issue) Statement:

Generated daily attendance report shows all staffs Attendance Summary are recorded as "Absent", and total staff work hours recorded as "00:00".

Description:

Time Attendance Mode was applied few years ago. Recently user wished to generate daily attendance report only to discover that all staffs shows total work hours recorded as '00:00'.

System Application:

Time Attendance Mode

Symptom and Finding:

At Daily Attendance Report, 'Work' and 'Work Hour' time and duration for all staff are shown as '00:00' and Attendance Summary for all staff are shown as 'Absent'.
xPortal3000 Daily Attendance Report

Figure 1: Generated Daily Attendance Report where all Work and Work Hour Time and Duration shown as 00:00 

When users tried to generate transaction report, the software prompted 'No Data Found!' message window: 

Figure 2: No Data Found! Message Window

Cause:

  • User used many controllers and has many staff records, hence a lot of transaction will be pulled up from the controllers to software.
  • Some transactions may yet to be updated into transaction reporting which caused the software to not be able to generate the report.

Solution

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary

  • Use Restore Translog Tool built-in xPortal3000 to restore translog data.


Step-by-step Guide:

  • Use Restore Translog Tool built-in xPortal3000 to restore translog data:

Step1: STOP Service at xPortal3000 Server Configuration Manager. 

xPortal3000 Server Configuration Manager
Figure 3: xPortal3000 Server Configuration Manager.

Step 2: Go to Utilities tab and click Restore Transaction Tool. The following windows will be shown:
Utilities Tab
Figure 4: Utilities Tab.

Restore Transaction Tool Window
Figure 5: Restore Transaction Tool Window.

Step 3: Ensure the TransLog Folder location is correct. Select the Restore Transaction From date & time and Restore Transaction To data & time to select the duration that users wished to restore the trans logs from.


Step 4: Click Start button to start restore the Trans Log until complete.

Document Date

23/3/2018 (Rev 1.0)

PROOF-READ

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