During First Time Registration of Visitor Card User, the Software Showed Error Message of "No Visitor Card is Available"

Problem (Issue) Statement:

During first time registration of visitor card user, the software showed error message of "No Visitor Card is Available"


Description:

Why did the software showed the "No visitor card is available" error message during the first time registration of the visitor card user?


Related Software:

  • xPortalNet v1.5

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

After installing the xPortalNet software, user would like to run Visitor Management System for the first time and assign visitors with a visitor card access. However, the software then prompts the error message to indicate "No visitor card is available", as shown below:
No Visitor Card is Available Error Message
Figure 1: No Visitor card is Available! Error Message


Information

For newer versions of xPortalNet v1.5, the software will be showing two (2) additional message as follows: 
No Visitor Card or Visitor Badge is Available
Figure 2: No Visitor Card or Visitor Badge is Available! Error Message


The following message will be shown to indicate that "No visitor card or visitor badge is available!"  
No Visitor Card or Visitor Badge is Available Error Message
Figure 3: No Visitor Card or Visitor Badge is Available! Error Message

Next, the following error message will be shown to indicate that "No visitor card is available! Please go to Card Records to add visitor card first!" 

Figure 4: No Visitor Card is Available! Please go to Card Records to Add Visitor Card First! Error Message

Cause:

This is caused by user / installer not pre-defining cards in the Card Record database.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

  • To add Visitor Card in Card Record.


Step-by-step guide:

  • To add visitor card in Card Record:

Step 1: Go to xPortalNet Client > Data Setup > Access Data Setting > Card Records and click Get Now!
Card Detail List Window
Figure 5: Card Detail List Window


Step 2: Click Add to add a new Visitor Card in the Card Detail Setup window as shown below: 
Card Detail Setup Window
Figure 6: Card Detail Setup Window


Add Icon
Figure 7: Add Icon


Step 3: Enter the Card No into Card No field to assign the card as Visitor Card and click OK to continue.
Add Card Detail Window
Figure 8: Add Card Detail Window


Step 4: The following message will be shown to indicate that the record is added. Click OK to continue.
Record Added Window
Figure 9: Record Added Window


Step 5: The software will return to Card Detail Setup window. Notice that the new visitor card number is recorded in list.
Card Detail Setup Window Showing the Newly Added Visitor Card
Figure 10: Card Detail Setup Window Showing the Newly Added Visitor Card 


The Newly Added Visitor Card
Figure 11: The Newly Added Visitor Card


Step 6: To continue adding a new visitor card, repeat steps 2 to 4. To exit from the window, click Close.


Step 7: Now, you may proceed to xPortalNet Client > Visitor Still In List tab to register the visitor.

Knowledge Base Link

Users can refer to How to Setup Visitor Management System on xPortalNet Software to continue the registration for visitor.

Common issue

NIL

Date Documentation:

17/10/2018 (Rev 1.0)

PROOF-READ

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