Why did the xPortalNet Comm Server Showed 'Cannot Open Database "XPNDB" Requested by the Login. The Login Failed' Error Message During the Initialization of xPortalNet Database

Problem (Issue) Statement:

Why did the xPortalNet Comm Server Showed 'Cannot Open Database "XPNDB" Requested by the Login. The Login Failed' error message during the initialization of xPortalNet database

Description:

When users launch xPortalNet Comm Service and Server to initialize a new xPortalNet database, the xPortalNet software showed the 'Cannot open database "XPNDB" requested by the login. The login failed' error message.

Related Software:

  • xPortalNet v1.0.0.50 above
  • xPortalNet v1.5 above

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

After launching the xPortalNet Comm Service and xPortalNet Server to initialize new database, the xPortalNet Server showed an error message to indicate 'Cannot open database "XPNDB" requested by the login. The login failed.' as below.
Cannot Open Database XPNDB Requested by the Login. The Login Failed Error Message
Figure 1: Cannot Open Database "XPNDB" Requested by the Login. The Login Failed Error Message


OR


Issue 1: Database 'XPNDB' already exists. Choose a different database name.

Figure 2: Database Initialization Failed! Please Check the Error Log! Database 'XPNDB' Already Exists. Choose a Different Database Name Error Message


OR


Issue 2: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.

Figure 3: Database Initialization Failed! Please Check the Error Log! [DBNETLIB][ConnectionOpen (Connect()).]SQL Server Does Not Exist or Access Denied Error Message

Cause:

This issue is caused by an improper way of configuring or initializing a new database, which could be due to a few reasons as below:

  • For Issue 1: During initializing the database at existing computer and SQL Server, user has deleted existing physical database (physical files in xPortalNet v1 folder) in Program Data folder without detaching the existing XPNDB in SQL Server beforehand, or
  • For Issue 2: During the first time initialization of database for xPortalNet software, the settings were configured incorrectly in the xPortal Comm Server Database Setting window, resulting in the software unable to access the SQL Server.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

  • To solve Issue 1 where the error message of "Database 'XPNDB' already exists. Choose a different database name" was shown.

  • To solve Issue 2 where the error message of "[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied" was shown.


Step-by-step Guide:

  • To solve Issue 1 where the error message of "Database 'XPNDB' already exists. Choose a different database name" was shown:

Step 1: Before removing any existing physical database in Program Data folder, users are required to detach the xPortalNet database in SQL Server software.

Knowledge Base Link

Users can refer to How to Detach xPortalNet database from SQL Server for the complete procedures to detach xPortalNet database.




  • To solve Database Initialization Failed error message to indicate "Please check the error log! [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied."

Step 1: Ensure that the SQL Server software does not register any of xPortalNet's databases under the Database folder. If any of the xPortalNet database software still exists under the Database folder, users are required to detach the database first in SQL Server.

Knowledge Base Link

Users can refer to How to Detach xPortalNet database from SQL Server for the complete procedures to detach xPortalNet database.




Step 2: Go to tool bar and right-click xPortalNet Comm Service icon. Click Stop.
Stopping xPortalNet Comm Service
Figure 4: Stopping xPortalNet Comm Service


Step 3: Go to C:\ProgramData\MicroEngine\xPortalNet v1 to delete the xPortalNet v1 folder.

Tip

Users can also choose to rename the folder to something like xPortalNet v1 (date) in order to keep the existing database.



Step 4: Right-click the xPortalNet Comm Service icon and click Start to initialize a fresh database again.
Starting the xPortalNet Comm Service to Initialize a Fresh Database Again
Figure 5: Starting the xPortalNet Comm Service to Initialize a Fresh Database Again


Step 5: Run the xPortalNet Server application.


Step 6: The xPortal Comm Server Database Setting window will be shown. User must fill in the Server Name and Password before clicking Initialize Database.
xPortal Comm Server Database Setting Window
Figure 6: xPortal Comm Server Database Setting Window


Tips

How do I know my Server Name and Password?

Run the SQL Server Management Studio, refer to the Server Name and login Password in the Connect to Server window.

Figure 7: Server Name and Password Field in Connect to Server Window



Note

Please ensure that the password entered is able to connect to the SQL Server.



Step 7: The xPortalNet Comm Server window indicating that the "Database Created Successfully!" message will be shown. Click OK.
Database Created Successfully Window
Figure 8: Database Created Successfully Window

Common Issue:

  1. Incomplete / incorrect settings configuration in xPortal Comm Server Database window.
  2. Re-initializing new database on existing Server PC without properly removing or deleting existing database on SQL Server.

Date Documentation:

3/12/2018 (Rev 1.0)

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