Why xPortal Communication Gateway (Polling Agent) software always stops working after running for a while

Problem (Issue) Statement:

Why xPortal Communication Gateway (Polling Agent) software always stops working after running for a while

Description:

Site is running xPortalNet Server supported by 3 copies of Polling Agent software. However, it is discovered that 1 copy of the Polling Agent software always stopped working after running for a while.

Related Software:

  • xPortalNet v1.5

Related Hardware:

NA

System Application:

Door Access System & Time attendance System

Symptom and Finding:

Further investigation indicated that accesses to XPTempTR1.txt and XPTransConsumer.txt are denied by the PC:

  • Access to the path 'C:\ProgramData\MicroEngine\xPortalNet v1\Server\TransLog\PollingAgent\TransLog\XPTempTR1.txt' is denied.
  • Access to the path 'C:\ProgramData\MicroEngine\xPortalNet v1\Server\TransLog\PollingAgent\TransLog\XPTransConsumer.txt' is denied.

Cause:

Polling Agent's PC does not have user permission to access C:\ProgramData\MicroEngine.

Solution:

  • Changed the security settings to grant full control to 'C:\ProgramData\MicroEngine'.
    xPortalNet v1 Properties Window
    Figure 1: xPortalNet v1 Properties Window

Note

To troubleshoot the software, please look at the check-logs in Event Viewer and error logs in the designated log folder for the full details on the error messages.

Date Documentation:

2/4/2018  (Rev 1.0)

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