How to Troubleshoot the Issue where the Polling Agent Status is Shown as Down in xPortalNet Software

Problem (Issue) Statement:

How to troubleshoot the issue where the Polling Agent status is shown as Down in xPortalNet software

Description:

After configuring the xPortal Communication Gateway at the Polling Agent PC, the Polling Agent status is shown as Down in xPortalNet software.

The software also failed to record any transaction from the Polling Agent.

Related Software:

  • xPortalNet v1.5
  • xPortalNet HS v1.8
  • xPortal Communication Gateway v1.0
  • xPortal Communication Gateway HS v1.8

Related Hardware:

NIL

System Application:

  • Door Access System
  • Lift Masking Access System
  • Turnstile Access System
  • Vehicle Access System

Symptom and Finding:

The xPortalNet Server showing the Polling Agent status as DOWN in the Remote Communication Gateway tab.
Polling Agent Status Shown as Down in Remote Communication Gateway Tab 
Figure 1: Polling Agent Status Shown as Down in Remote Communication Gateway Tab

Cause:

  • IP configuration of the system is incorrectly configured.
  • xPortal Communication Gateway is not running with administrator permission.
  • xPortal Communication Gateway in the Polling Agent PC is not running.

Solution:







Summary:

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Step-by-step Guide:

  • To cross check IP configuration for Polling Agent in xPortalNet software and assign a static IP address for Polling Agent PC:

Step 1: Go to xPortalNet Comm Server Server Admin Communication Gateway.
Communication Gateway Button Under Server Admin Menu 
Figure 2: Communication Gateway Button Under Server Admin Menu

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Step 2: Select the affected Poling Agent. Click Modify.
Modifying the Properties of the Affected Polling Agent 
Figure 3: Modifying the Properties of the Affected Polling Agent

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Step 3: The Edit Polling Agent window will be shown. Make sure the IP Address configured under the Remote IP Address field is the same as the pre-configured static IP address for Polling Agent PC.
Edit Polling Agent Window 
Figure 4: Edit Polling Agent Window

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Knowledge Base Link

Users may refer to How to Pre-configure Network Connection for IP Controllers to ensure that the Polling Agent's PC has been assigned with Static IP Address.

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  • To ensure xPortal Communication Gateway is running with administrator permission:

Step 1: At the Polling Agent PC, click on the xPortal Communication Gateway icon once, right-click and select Properties.
Right-clicking xPortal Communication Gateway Icon and Click Properties 
Figure 5: Right-clicking xPortal Communication Gateway Icon and Click Properties

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Step 2: The xPortal Communication Gateway Properties window will then be shown. Click Compatibility tab. Under the Privilege Level section, tick the Run this program as an administrator tickbox. Click OK to save the changes.
xPortal Communication Gateway Properties Window 
Figure 6: xPortal Communication Gateway Properties Window

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  • To ensure xPortal Communication Gateway (Polling Agent) service is running at Polling Agent PC:

Step 1: Go to Show hidden icons at bottom right taskbar. Select the xPortal Communication Gateway Icon.
xPortal Communication Gateway Icon 
Figure 7: xPortal Communication Gateway Icon

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Step 2: Right click on the xPortal Communication Gateway icon and ensure that the services has been started. Notice that the start button has been grayed out and users will be unable to click it when the services has been started.
The xPortal Communication Gateway has been Started 
Figure 8: The xPortal Communication Gateway has been Started

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Step 3: If users are unable to find the xPortal Communication Gateway icon, go back to Desktop and double-click on xPortal Communication Gateway icon.
xPortal Communication Gateway icon 
Figure 9: xPortal Communication Gateway Icon

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Step 4: Go to Show hidden Icons list at bottom right taskbar, right-click the xPortal Communication Gateway icon and select Start or Agent.
Selecting Agent on xPortal Communication Gateway Icon 
Figure 10: Selecting Agent on xPortal Communication Gateway Icon

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OR

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Clicking Start on xPortal Communication Gateway Icon 
Figure 11: Clicking Start on xPortal Communication Gateway Icon

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Step 5: Launch the Polling Agent software. Note that under the Transaction header, the software has recorded the transaction that the "Communication Agent Start Up".
Communication Agent Start Up Transaction
Figure 12: Communication Agent Start Up Transaction

Common Issue

NIL

Date Documentation:

30/3/2020 (Rev 2.0)

PROOF-READ

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