Why the Polling Agent (Remote Communication Gateway) Status is Frequently Shown as Down in xPortalNet Software

Problem (Issue) Statement:

Why the Polling Agent (Remote Communication Gateway) status is frequently shown as down in xPortalNet software

Description:

After restarting the service of Polling Agent, the communication gateway status will be shown as Down again after a few hours or several days.

Related Software:

  • xPortalNet HS v1.8.0.28
  • xPortal Communication Gateway HS v1.8.0.4

Related Hardware:

NIL

System Application:

  • Door Access System
  • Lift Masking Access System
  • Turnstile Access System
  • Vehicle Access System

Symptom and Finding:

The xPortalNet HS software is unable to receive event transactions from controllers assigned with connections under Polling Agent (Remote Communication Gateway) and the xPortalNet HS software showed the Polling Agent status as DOWN.
Polling Agent Status Shown as Down 
Figure 1: Polling Agent Status Shown as Down

Cause:

  • The Polling Agent PC has 2 network adapters and user assigned the same static IP address for both network adapters. This thus affects the network communication and results in the Polling Agent status intermittently being shown as Down.
    Polling Agent PC Having Two Network Adapters 
    Figure 2: Polling Agent PC Having Two Network Adapters

Solution:

Summary:

  • Method 1: Remove the assigned static IP address from one of network adapter.

  • Method 2: Disable one of the network adapters.



Note

Users may choose EITHER Method 1 or Method 2 to complete the process.


Step-by-step Guide:

  • Method 1: Remove the assigned static IP address from one of the network adapter:

Step 1: Go to Control Panel All Control Panel Item Network and Sharing Center. On left panel menu, click Change adapter setting.
Change Adapter Settings Button on Left Panel Menu in Network and Sharing Center Window 
Figure 3: Change Adapter Settings Button on Left Panel Menu in Network and Sharing Center Window

.

Step 2: Select one of network adapter (NIC), right click and select Properties.
Right-clicking unsafe-One of the Network Adapters 
Figure 4: Right-clicking One of the Network Adapters

.

Step 3: The Local Area Connection Properties window will then be shown. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties
Local Area Connection Properties Window 
Figure 5: Local Area Connection Properties Window

.

Step 4: The Internet Protocol Version 4 (TCP/IPv4) Properties window will be shown. Select Obtain an IP address automatically. Click OK to continue.
 
Figure 6: Internet Protocol Version 4 (TCP/IPv4) Properties Window

.

.

  • Method 2: Disable one of the network adapters:

Step 1: Click on the Start button and click Control Panel.
Control Panel in the Start Menu 
Figure 7: Control Panel in the Start Menu

.

Step 2: The Control Panel window will be shown as below. Select Network and Internet to continue.
Control Panel Window 
Figure 8: Control Panel Window

.

Step 3: The Network and Internet window will then be shown. Click Network and Sharing Center to continue.
Network and Internet Window 
Figure 9: Network and Internet Window

.

Step 4: Next, the Network and Sharing Center window will be shown. At the left menu panel, click Change adapter settings.
Change Adapter Settings on the Left Menu Panel of Network and Sharing Center Window 
Figure 10: Change Adapter Settings on the Left Menu Panel of Network and Sharing Center Window

.

Step 5: The Network Connections window will then be shown. All the network adapters will be shown here. Notice that there are two (2) network adapters.
Two Network Adapters Shown in the Network Connections Window 
Figure 11: Two Network Adapters Shown in the Network Connections Window

.

Step 6: Select one of network adapter and click Disable this network device.
Disabling One of the Network Adapters 
Figure 12: Disabling One of the Network Adapters

Common Issue

NIL

Date Documentation:

03/4/2020 (Rev 2.0)

PROOF-READ

.

Related Articles.

Containing the label "polling-agent"

Filter by label

There are no items with the selected labels at this time.

.


.

© MicroEngine Technology Sdn Bhd (535550-U). All rights reserved.