How to Solve the Problem for Polling Agent where the xPortalNet Software did not Record any Transaction in the Latest Event List

Problem (Issue) Statement:

How to solve the problem for Polling Agent where the xPortalNet software did not record any transaction in the Latest Event List

Description:

This article will guide users to solve the problem for Polling Agent where the xPortalNet software did not record any transaction in the Latest Event List.

Related Software:

  • xPortalNet
  • Polling Agent

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

The Polling Agent status is shown as UP in the xPortalNet Server, but there are no transactions recorded in the Latest Event List window.

Polling Agent Status Shown as Up
Figure 1: Polling Agent Status Shown as Up
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Latest Event List Window Not Recording Any Transactions
Figure 2: Latest Event List Window Not Recording Any Transactions

Cause:

  • The xPortal Communication Gateway folder is not allowed full accessibility permission.

Solution:







Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

  • To change the file / folder permissions of xPortal Communication Gateway folder.


Step-by-step Guide:

  • To change the file / folder permissions of xPortal Communication Gateway folder:

Step 1: Go to "C:\\Program Files\MicroEngine". Right-click on the xPortal Communication Gateway folder and select Properties.
Selecting Properties from the Right-Click Menu of xPortal Communication Gateway Folder 
Figure 3: Selecting Properties from the Right-Click Menu of xPortal Communication Gateway Folder

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Step 2: The xPortal Communication Gateway Properties window will then be shown. Click Security tab > Edit to change the group or user permissions.
Edit Button in Security Tab
Figure 4: Edit Button in Security Tab

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Step 3: In the Permissions for Users section, select the PC users who will login to the Polling Agent, and tick Allow under the field of Full control.
Selecting the Users who will Login to the Polling Agent
Figure 5: Selecting the Users who will Login to the Polling Agent

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Ticking the Allow Tickbox under Full Control Field
Figure 6: Ticking the Allow Tickbox under Full Control Field

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Step 4: Click Apply OK to save the changes.
Clicking Apply and OK to Save the Changes
Figure 7: Clicking Apply and OK to Save the Changes

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Step 5: Users can now restart the xPortalNet and Polling Agent software. Verify that the Latest Event List window in xPortalNet is now showing transactions recorded by the Polling Agent.
Latest Event List Window Showing Recorded Transactions from Polling Agent
Figure 8: Latest Event List Window Showing Recorded Transactions from Polling Agent

Common Issue

NIL

Date Documentation:

28/3/2020 (Rev 1.0)

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