How to Troubleshoot General Hardware Problems of the XP-SK32 Controller

Problem (Issue) Statement:How to troubleshoot general hardware problems of the XP-SK32 controller
Description:

XP-SK32 is MicroEngine's legacy standalone controller. This article will guide users on how to troubleshoot the general hardware problems of the XP-SK32 controller.

Related Software:NIL
Related Hardware:
  • XP-SK32
System Application:NIL
Symptom and Finding:
  • Unable to detect card / controller did not respond when users flashed a valid access card.
  • EM lock does not release when access is granted / door is always released even when security is ON.
  • No response from the controller when user pressed the exit button.
Cause:
  • Incorrect wiring connection
  • No power supply to the controller
  • Relay board is not functional
  • Controller is faulty
  • EM lock is faulty
  • Exit button is faulty
Solution:

Summary:

  • Ensure that the wiring are terminated correctly

  • General hardware troubleshooting

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Step-by-step Guide:

  • Ensure that the wiring are terminated correctly:

Step 1: Please follow the correct wiring connection diagram.

Knowledge Base Link

Users can refer to How to Connect XP-SK32 Controller to Door Accessories for the complete wiring termination diagram.

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  • General hardware troubleshooting:

Step 1: Ensure that the power supply unit to the controller is switched ON and is functional. Check the voltage into the controller and ensure that the controller receives the full 12VDC.


Step 2: Check and ensure that the relay board is functional. Users can swap out the current relay board unit with a known functioning unit to test if the currently connected unit is faulty.


Step 3: Check and ensure that the controller is functional. Users can swap out the current controller with a known functioning unit to test if the currently connected unit is faulty.


Step 4: Check and ensure that the EM lock is functional. Users can swap out the current EM lock with a known functioning unit to test if the currently connected unit is faulty.


Step 5: Check and ensure that the exit button is functional. Users can swap out the current exit button unit with a known functioning unit to test if the currently connected unit is faulty.


Step 6: If any of the units above is tested to be faulty, please send those unit(s) back to MicroEngine's Service Center for repairs.

Common Issues:NIL
Porting Date:27/3/2019

PROOF-READ

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