Why are Users Unable to Generate Transaction Report with xPortal3000 Client Showing Error Message Indicating "No Data Found"

Problem (Issue) Statement:

Why are users unable to generate transaction report with xPortal3000 client showing error message indicating "No Data Found"

Description:

Why are users unable to generate transaction report with xPortal3000 client showing error message indicating "No Data Found"?

Related Software:

  • xPortal3000 v3.0.0.30

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

At Program Data > MicroEngine > xPortal3000 > Server, open the Exception text file and discovered that computer does not have enough space on the disk as the system keep generating XPclsTemTransErr file.
Exception Text File
Figure 1: Exception Text File



Figure 2: XPcIsTemTransErr Files Generated by the Software

Cause:

The cause of the problem is that the transaction data at XPTempTR1 text file and the counting number at XPTransConsumer not tallied, which in turn caused xPortal3000 Service to not be able to write transaction data to XPNTR file.

Figure 3: Transaction data in XPTempTR1 Text File not Tallied with Counting Number in XPTransConsumer Text File

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

  • To use Restore Translog Tool to restore translog data.


Step by step guide:

  • To use Restore Translog Tool to restore translog data:

Step1: Open xPortal3000 Server Configuration Manager, click Stop to stop xPortal3000 Service.
xPortal3000 Server Configuration Manager
Figure 4: xPortal3000 Server Configuration Manager.


Step 2: Go to Utilities tab and click Restore Transaction Tool.
Utilities Tab
Figure 5: Utilities Tab.


Step 3: The Restore Transaction Tool window will be shown.
Restore Transaction Tool Window
Figure 6: Restore Transaction Tool Window.


Step 4: Select the Restore Transaction From date & time and Restore Transaction To data & time that you prefer the transaction to be restored.
Restore Transaction From and To Dates
Figure 7: Restore Transaction From and To Dates


Step 5: Click Start button to start restore the Trans Log until complete.
Click Start to Begin Restoring Transaction Log
Figure 8: Click Start to Begin Restoring Transaction Log

Common issue

  • This problem will commonly happen if users shut down the computer without properly stopping xPortal3000 Service.

Date Documentation:

18/10/2018 (Rev 1.0)

PROOF-READ

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