How to Troubleshoot the Issue where Users are Unable to Restore Transaction using Restore Trans Log Tool in xPortalNet Software

Problem (Issue) Statement:

How to troubleshoot the issue where users are unable to restore transaction using Restore Trans Log Tool in xPortalNet software

Description:

When user discovered that there are missing transactions, users attempted to restore the missing transaction via the Restore Trans log Tool.

However, the users are unable to restore the missing transactions by using the Restore Translog Tool.

Related Software:

  • xPortalNet

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

When users attempt to restore missing transactions using Restore Trans Log Tool, the following error message is shown and the Restore Trans Log Tool stopped responding.
RestoreTransLog.exe has Stopped Working Message
Figure 1: RestoreTransLog.exe has Stopped Working Message

Cause:

  • The configuration file for the Restore Trans Log Tool is not in the correct location.

Solution:







Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

  • To check the Configuration File Path in Restore Trans Log Tools.

  • To relocate the configuration file to default location.


Step-by-step Guide:

  • To check the Configuration File Path in Restore Trans Log Tools:

Step 1: Ensure that the xPortalNet Services is stopped.

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Step 2: Go to the location of C:\ProgramData\MicroEngine\xPortalNetv1\Server\Database. If the XPDBSetting.cfg file is not located in the Database folder, users will have to relocate the configuration file to this folder.

Note

Only the Configuration File Path (XPNDBSetting.cfg file must be in the default location of C:\ProgramData\MicroEngine\xPortalNetv1\Server\Database. 


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  • To relocate the configuration file to default location:

Step 1: Locate the XPDBSetting.cfg file. Select the file, right-click and click Copy.
Copying the XPDBSetting.cfg File
Figure 2: Copying the XPDBSetting.cfg File

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Step 2: Go to the default location (C:\MicroEngine\xPortalNetv1\Server\Database). Right-click the folder and select Paste.
Pasting the XPDBSetting.cfg File 
Figure 3: Pasting the XPDBSetting.cfg File

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The XPDBSetting.cfg File Pasted in the Default Folder Location
Figure 4: The XPDBSetting.cfg File Pasted in the Default Folder Location

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Step 3: Users can then delete the XPDBSetting.cfg file in the old folder location.

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Step 4: Users can now launch the Restore Trans Log Tool again. Click Browse to set up all the main database configuration section (1). Select the Restore Transaction From and Restore Transaction To dates (2), and click Start (3) to begin the transaction restoring process.
Restore Trans Log Tool Window
Figure 5: Restore Trans Log Tool Window

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Step 5: The window will then indicate the progress of the restore transaction process. Please wait until the progress completes before running the xPortalNet software.
Restore Transaction Progress 
Figure 6: Restore Transaction Progress

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Knowledge Base Link

Users may refer to How to Use the Restore Translog Tool to Restore Missing Transaction Data in xPortalNet Software for the complete guide to use the Restore Trans Log Tool.

Common Issue

NIL

Date Documentation:

10/4/2020 (Rev 1.0)

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