How to Restore xPortal3000 Database

Problem (Issue) Statement:

How to restore xPortal3000 database

Description:

A guide to restore existing xPortal3000 database.

Related Software:

  • xPortal3000 v3.0.0.12

Related Hardware:

NA

System Application:

  • xPortal3000 Standard Software

Symptom and Finding:

NA

Cause:

For first time restoration to existing xPortal3000 database.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary

  • To restore xPortal3000 database.


Before performing the following steps, please ensure that the xPortal3000 Client has been closed.


Step-by-step Guide:

  • To restore xPortal3000 database:

Step 1: Open xPortal3000 Server Configuration Manager and click Stop to stop the xPortal3000 Services in the System Status tab.
Ensuring that xPortal3000 Service State is Stopped
Figure 1: Ensuring that xPortal3000 Service State is Stopped


Step 2: Go to Database Setting tab and click Restore.
Restore Button in Database Settings Tab
Figure 2: Restore Button in Database Settings Tab


Step 3: The Restore Database Wizard (Firebird) window will be shown as below. Click Next to continue.
Restore Database Wizard Window
Figure 3: Restore Database Wizard Window


Step 4: The Backup File window will be shown as below. Go to Browse to select the folder location of the backup file to be restored and click Next to continue.
Backup File Window
Figure 4: Backup File Window


Step 5: The Source window will be shown as below. Select the items to be restored from the backup file and click Next to continue.
Source Window
Figure 5: Source Window


Step 6: The Destination window will be shown as below. Check the Restore and replace existing database checkbox. For a fresh installation, check Restore as new database. Click Next to continue.
Destination Window
Figure 6: Destination Window


Step 7: The following message window will be shown to confirm the database restoration process. Click Yes to start restoring database.
Database Restoration Confirmation
Figure 7: Database Restoration Confirmation


Step 8: The Restore Database Wizard window will be shown once the database restoration process is started. Upon completing the restoration process, the following message window will be shown indicating that the database restoration process is completed. Click Ok and then click Next on Restore Database Wizard window.
Restore Database Wizard Window
Figure 8: Restore Database Wizard Window


Step 9: The Restore Database Completed window will be shown to indicate that database restoration is completed. Click Finish.
Restore Database Completed Window
Figure 9: Restore Database Completed Window

Date Documentation:

19/7/2018 (Rev 1.0)

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