Why xPortalNet Software Failed to Send the Test SMS for SMS Notification Feature

Problem (Issue) Statement:Why xPortalNet software failed to send the test SMS for SMS Notification feature
Description:

Users failed to send the Test Sending SMS in order to test the setup for SMS Notification feature.

Related Software:
  • xPortalNet
Related Hardware:NIL
System Application:NIL
Symptom and Finding:

After clicking Test Sending SMS, the xPortalNet software prompted the following error messages:
SMS Could Not be Sent Error Message
Figure 1: SMS could not be sent. Failed to send sms! Please check your settings Error Message

Cause:
  • No connection between Server PC and GSM Modem
  • SMS Notification is turned off.
  • Incorrect GSM Modem Comm Port No.
Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Step 1: Users have to ensure that the GSM Modem unit is powered on, and is connected to the Server PC.


Step 2: Check and ensure that there is a SIM card properly inserted into the SIM card slot.

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  • To turn on the SMS Notification feature:

Step 1: Go to xPortalNet Server > System Properties > Modify > Email & SMS tab. The Email & SMS window will be shown. At the SMS Notification field, select "Yes". Click OK to save the changes.

Figure 2: SMS Notification Field in Email & SMS Window


Step 2: The software will then prompt the following message windows to indicate that the record is updated and to remind users to download the settings to the respective controllers.
Record Updated Window
Figure 3: Record Updated Window


Message to Remind Users to Download Settings to Controller
Figure 4: Message to Remind Users to Please go to xPortalNet Client software to download the settings (Device Comm → Send Door Controller Settings → Door Parameters)


Step 3: Back at the System Properties window, click Close to exit from the window.

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  • To configure the GSM Modem Comm Port No correctly:

Step 1: Users should check from the Device Manager window to see which comm port is the GSM Modem connected to in the Server PC.

Step 2: Go to xPortalNet Server > System Properties > Modify > Email & SMS tab. The Email & SMS window will be shown. At the GSM Modem Comm Port field, select the correct comm port to which the GSM Modem is connected to. Click OK to save the changes made.
Choosing the Correct GSM Modem Comm Port Number
Figure 5: Choosing the Correct GSM Modem Comm Port Number

Step 3: The software will then prompt the following message windows to indicate that the record is updated and to remind users to download the settings to the respective controllers.
Record Updated Window
Figure 6: Record Updated Window

Message to Remind Users to Download Settings to Controller
Figure 7: Message to Remind Users to Please go to xPortalNet Client software to download the settings (Device Comm → Send Door Controller Settings → Door Parameters)

Step 4: Back at the System Properties window, click Close to exit from the window.

Common Issues:NIL
Porting Date:1/3/2019

PROOF-READ

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