I have Just Installed a New XP-GT or XP-GTR Controller but it's Status is Shown as Down in Device List

I have Just Installed a New XP-GT or XP-GTR Controller but it's Status is Shown as Down in Device List

Problem (Issue) Statement:

I have just installed a new XP-GT or XP-GTR controller but it's status is shown as Down in Device List

Description:

After installing the new XP-GT or XP-GTR controller, the controller status in Device List is shown as "Down".

The controller failed to establish communication with the software.

Related Software:

NIL

Related Hardware:

  • XP-GT3200

  • XP-GT3500

  • XP-GTR1200

  • XP-GTR1500

System Application:

Door Controller Mode

Symptom and Finding:

  • Uplink icon 

    is not indicated on the controller's screen.

  • There are no transaction recorded from the controller.

  • XP-GT / XP-GTR does not respond when settings are downloaded to the controller. The software's Delivery Report shows sent error to the controller

  • The controller status is shown as down at the software after configuring the network settings. However, at the Windows Command Prompt, the controller can be pinged.

Cause:

There are several potential causes which contributes to the same symptoms:

Connection Settings:

  1. Controller is not connected to a network switch / router using a network cable if it is to be connected via LAN connection.

  2. The network router / switch has not been powered up.

  3. The network cable used is in faulty condition

 

Network Settings:

  1. Dynamic IP Address is used for the Server PC's IP Address, thus the controller is unable to establish communication with the Server PC as a result of IP Address changes.

  2. IP Address conflict.

  3. Incorrect network configurations was set in the Network Parameters in the controller's settings.

  4. Incorrect Remote IP Address / Controller Model No. / Door Unit No was set in the software server.

  5. The controller communication is blocked by firewall

Solution:

Information

This article serves as a starting platform for users to begin troubleshooting controller status "down" issues

 

Summary:

.

Step-by-step Guide:

  • Check the Uplink Communication Icon:

Step 1: Check the Uplink Communication icon 

 on the LCD of the controller. If the icon is present and not blinking, this indicates that the controller is able to establish communications with the software.

Figure 1: Uplink Communication Icon at the LCD Screen of the Controller

 

Step 2: If the Uplink Communication icon is absent, then it means that the controller failed to communicate with the software, users should then proceed with the remainder of this article.


Figure 2: Uplink Communication Icon Not Shown at the LCD Screen of the Controller

 

 

  • General Troubleshooting steps for LAN Communication:

Step 1: Check and ensure that the controller is connected to a network switch / router, and that the network switch / router is powered on and in running condition.

 

Step 2: Check and ensure that the network cable used is in good, working condition. Users are advised to test the connectivity of the cable by using a network cable tester.


Figure 3: LAN Cable Tester Device

 

Step 3: Before assigning any IP Address, users should ensure that the IP Address does not conflict with other devices. To do that, users must try to ping the IP Address before hand via Windows Command Prompt.


Figure 4: Example of Unused IP Address (192.168.1.100)

 


Figure 5: Example of Occupied IP Address (192.168.1.239)

 

Step 4: To check whether the Server PC's IP Address is static or dynamic,

 1. Go to Network Connections window, right-click on the Ethernet and select Properties.

 


 Figure 6: Network Connection Window

 

 2. The Ethernet Properties window will then be shown. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.

 


 Figure 7: Ethernet Properties Window

 

3. The Internet Protocol Version 4 (TCP/IPv4) Properties window will be shown. Ensure that the Use the following IP address checkbox is ticked, enter IP address of the Server PC and click OK.
 


Figure 8: Internet Protocol Version 4 (TCP/IPv4) Properties Window

 

Step 5: Users should also check and ensure that the Network Parameters configured on the controller LCD screen matches with the configuration in the software.

 

 

  • To allow the application to communicate through Windows Firewall:

Step 1: Users must allow the application (xPortal software) to communicate through the Windows Firewall.

Knowledge Base Link

Users can refer to How to Allow Software to Communicate Through Windows Firewall for the complete steps to allow the application to communicate through the Windows Firewall.

Common Issues:

NIL

Porting Date:

29/11/2018 (Rev 1.0)

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