How to Troubleshoot the Issue where XP-SNET Controller is Unable to Send Data to xPortalNet Software

Problem (Issue) Statement:How to troubleshoot the issue where XP-SNET controller is unable to send data to xPortalNet software
Description:

This article will guide users on how to troubleshoot the issue where XP-SNET controller is unable to send data to xPortalNet software.

Related Software:
  • xPortalNet
Related Hardware:
  • XP-SNET
System Application:NIL
Symptom and Finding:
  • controller status is shown as down.
  • no communication from controller to software (no transaction is shown in the software)
Cause:
  • Network cable (RJ45 cable) is not working properly / MCI unit faulty
  • Incorrectly configured connection setting 

Warning!

The XP-SNET controller will not send fire alarm signal over to the connected XP-SNET-E32R and/or XP-SNET-E248 extension boards if the configuration settings for the XP-SNET controller is not completed.

Complete the configuration settings for XP-SNET controller in order for XP-SNET-E32R and/or XP-SNET-E248 to respond accordingly to fire alarm signals.

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Summary:

  • To check the Uplink connection.

  • To check the connection settings.

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Step-by-step Guide:

  • To check the Uplink connection:

Step 1: Before checking the uplink connection, please ensure that the wiring termination for the XP-SNET controller is connected properly.

Knowledge Base Link

Users may refer to How to Connect XP-SNET controller to Door Accessories and Extension Boards for the complete wiring termination procedures.

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Step 2: Please check the uplink connection on the XP-SNET controller as per the following table.

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  • To check the connection settings:

Step 1: Check and ensure that the address setting for the ADDRESS DIP switch on the XP-SNET controller is the same as the Unit No configuration in the Controller Setup window (xPortalNet Server > Server Admin > System Device Setup > Controller

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Step 2: For LAN connection, check and ensure that the controller IP address configured in the Web Diagnostic is the same as the Remote IP Address in Connection Setup window (xPortalNet Server > Server Admin > Connection Setup). Also, ensure that the Server IP address in the Web Diagnostic is the same as the Server PC's IP Address.

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Step 3: For MCI connection, check and ensure that the Comm Port No connecting to the MCI is the same as the configured Comm No setting in Connection Setup window (xPortalNet Server > Server Admin > Connection Setup).

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Common Issues:

NIL

Porting Date:19/4/2019

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