How to Troubleshoot LAN Connection Issues with XP-M2000i or XP-M2300i Controllers

Problem (Issue) Statement:

How to troubleshoot LAN connection issues with XP-M2000i or XP-M2300i controllers

Description:After installation and configuration of the XP-M2000i controller, the controller's status in xPortal software is shown as "Down".
Related Software:
  • xPortal2005
  • xPortal3000
  • xPortalNet
Related Hardware:
  • XP-M2000i
  • XP-M2300i
System Application:NIL
Symptom and Finding:
  • Controller status is shown as "Down" from the Device List window at the xPortal software.
  • No transaction is shown in the software.
  • The yellow LED at the RJ45 network port is not blinking.
  • The controller cannot establish uplink connection to the software, but users are able to ping the controller's IP address.
Cause:
  • The network cable (RJ45 cable) is not properly connected to the LAN port and is therefore not working properly.
  • The network settings are not configured properly.
Solution:

Warning!

We do not recommend controllers and PC communication to be connected via Wifi (using Wifi dongles) as Wifi connection is unstable and can make controller statuses be shown as "Down".

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Summary:

  • To check network cable connection.

  • To check the network settings.

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Step-by-step Guide:

  • To check network cable connections:

Step 1: Users are advised to check and ensure that the network cable is properly plugged into the LAN port. If the network cable is crimped by the wiring service providers, ensure that the individual strands of cable within the RJ45 terminal is properly terminated.

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Step 2: Users are also advised to check the network cable condition to ensure that it is functional using a network cable tester.

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  • To check the network settings:

Step 1: Check and ensure that the network settings in web diagnostic is configured properly.

Knowledge Base Link

Users can refer to How to Pre-configure Network Connection for IP Controllers for the complete network settings procedures in web diagnostic.

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Step 2: Check and ensure that the network settings in the xPortal software is configured properly.

Knowledge Base Link

Common Issues:NIL
Porting Date:29/3/2019

PROOF-READ

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