Why does the Connected Suprema BioMini Fingerprint Reader Not Able to Capture Fingerprint

Problem (Issue) Statement:

Why does the connected Suprema BioMini fingerprint reader not able to capture fingerprint

Description:

After connecting the new Suprema BioMini fingerprint reader to the Client PC, user attempt to capture fingerprint by pressing the Start Capturing. xPortal3000 responded with a "Scanner is not connected" error message.

Related Software:

xPortal3000 v3.0.0.28

Related Hardware:

Suprema BioMini Scanner

System Application:

NA

Symptom and Finding:

After pressing Start Capturing, xPortal3000 software prompted "Scanner is not connected" error message. The sensor indicator on BioMini unit also does not turn on.

Figure 1: Scanner is Not Connected Error Message

Upon troubleshooting the Device manager, it is found that the driver for Suprema Fingerprint Scanner (Ver.02) is not installed.

Figure 2: Suprema Driver not Installed in Device Manager

Cause:

The driver for Suprema Fingerprint scanner was not installed.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary

  • To install Suprema Fingerprint driver.

Step by step

  • To install Suprema Fingerprint driver:

Step 1: Unplug the BioMini scanner from Client PC.


Step 2: The driver for the BioMini can be obtained from the installation CD in the BioMini packaging box. Double-click on the driver installer file.
Suprema Fingerprint Driver Installer file
Figure 3: The Suprema Fingerprint Driver Installer File


Step 3: The InstallShield Wizard window will be shown. Follow the instructions to install the driver. Click Finish to complete the installation steps before plugging the BioMini to the Client PC.
InstallShield Wizard Window
Figure 4: InstallShield Wizard Window


Step 4: Open the Device Manager window to verify that the BioMini's driver is installed properly.
Device Manager Window
Figure 5: Device Manager Window


Step 5: Expand the Universal Serial Bus controllers tab. Right-click Suprema Fingerprint Scanner (Ver.02) > Properties. The Suprema Fingerprint Scanner (Ver.02) Properties window will be shown. Ensure that the "Device status" field is indicated as "This device is working properly."
Suprema Fingerprint Scanner (Ver. 02) Properties Window
Figure 6: Suprema Fingerprint Scanner (Ver.02) Properties Window


Step 6: Go to xPortal3000 Client > Staff Record. Click Show Template Or Enrollment to test the functionalities of the Suprema BioMini Scanner device.


Step 7: Place the finger on BioMini's sensor and click Start Capturing. The scanner indicator will light up and the scanner device will be able to capture the fingerprint image. The captured image will be displayed at Finger Print Template Details window.
Fingerprint Template Details Window Showing the Captured Fingerprint Image
Figure 7: Finger Print Template Details Window Showing the Captured Fingerprint Image


Note

  • BioMini scanners purchased from MicroEngine are tested to work with all MicroEngine softwares.
  • MicroEngine will not take responsibility of BioMini scanners purchased from third party companies which results in any interruptions to MicroEngine's software operations.

Date Documentation:

6/6/2018 (Rev 1.0)

PROOF-READ

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