When Starting Up xPortalNet Comm Service, the Software Showed the Invalid License Key Error Message

Problem (Issue) Statement:

When starting up xPortalNet Comm Service, the software showed the Invalid License Key Error message

Description:

When user changed to a new xPortalNet computer and relocated the existing database, the customer completed all the steps in installing the xPortalNet software in the new Server PC.

However, the user is complaining that the newly bought dongle is unable to be detected after trying to start xPortalNet Comm Services, with the software showing an error message to indicate "Detect License Failure".

Related Software:

  • xPortalNet LIte v1.5.0.165

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

After the user plugged in the xPortalNet dongle license, when the user is trying to start xPortalNet Comm Services, the xPortalNet Services showed an error message to indicate "Detect License Failure Invalid license key!'

Figure 1: xPortalNet Services Showed the Detect License Failure Invalid License Key! Error Message


When the user checked on the Service Info window at the xPortalNet Comm Service icon, the Software License field showed "Key not detected' and Software License Error field showed "Invalid License Key!".

Figure 2: The About Window Showing Key Not Detected and Invalid License Key!

Cause:

After checking on the label on the dongle, it was found that the dongle was licensed to xPortalNet Lite version while the customers installed xPortalNet Standard version on site.

Solution:

Summary:

  • To perform physical check on sticker of Dongle License Key.

  • To check the software version through Service Info at xPortalNet Comm Service.

  • To check the License Key using Dongle Detection Tool (For MicroEngine Support team only).

  • Install the correct type of xPortalNet Services.

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Step-by-Step Guide:

  • To perform physical check on sticker of Dongle License Key:

Step 1: User must check the sticker label pasted on the Dongle License Key to confirm correct dongle was provided.
Sticker Label Pasted on Dongle License Key
Figure 3: Sticker Label Pasted on Dongle License Key

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  • To check the software version through Service Info at xPortalNet Comm Service:

Step 1: At the taskbar, right-click on the xPortalNet Comm Service icon > Check Service Info.
Check Service Info Option 
Figure 4: Check Service Info Option

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Step 2: The About window will then be shown. Double-confirm whether the version of the xPortalNet software as per highlighted in RED matches with the sticker label on the Dongle License Key.
About Window Showing the xPortalNet Software Version
Figure 5: About Window Showing the xPortalNet Software Version

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  • To check the License Key using Dongle Detection Tool (For MicroEngine Support team only):

Step 1: MicroEngine Support team to install the Dongle Detection Tool.

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Step 2: After successfully installing the software, open the MicroEngine USB Dongle Detection Tool software to continue.

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Step 3: The MicroEngine USB Dongle Detection Tool window will be shown as below.
MicroEngine USB Dongle Detection Tool v1.0.0.14 
Figure 6: MicroEngine USB Dongle Detection Tool v1.0.0.14

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Step 4: Plug-in the dongle license to USB 2.0 port.

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Step 5: Select the USB dongle based on the physical color of the Dongle License Key.
Selecting the Correct USB Dongle License Based on Color 
Figure 7: Selecting the Correct USB Dongle License Based on Color

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Step 6: After selecting the correct model for the Dongle License Key, click Read Info to continue.
Click Read Info to Read the Dongle Info 
Figure 8: Click Read Info to Read the Dongle Info

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Step 7: The info of the license for the Dongle Key will be shown as per below. User to confirm on the version for the xPortalNet software.
Confirming the Software Version is Correct 
Figure 9: Confirming the Software Version is Correct

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  • Installing the correct type of xPortalNet Services:

Step 1: Go to Control Panel Program Programs and Features.

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Step 2: Uninstall the current MicroEngine xPortalNet Service.

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Step 3: Install the correct type of xPortalNet Service.

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Step 4: Run the xPortalNet Services and wait a while for the software to recognize and detect the dongle license.
xPortalNet Comm Services Detecting the USB Dongle License 
Figure 10: xPortalNet Comm Services Detecting the USB Dongle License

Common Issues:

Install software version not matching with dongle license purchased.

Date Documentation:

9/9/2020 (Rev 1.0)

PROOF-READ

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