Why did the xPortalNet Services Failed to Detect the Plugged In Dongle Licence in Windows 10 Pro

Problem (Issue) Statement:

Why did the xPortalNet Services failed to detect the plugged in dongle licence in Windows 10 Pro

Description:

After installing the Rockey 4 driver in the xPortalNet Server PC and plugging in the USB dongle, the xPortalNet software is still unable to detect the USB dongle licence.

Related Software:

  • xPortalNet

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

After installing the Rockey 4 driver in the xPortalNet Server PC and plugging in the USB dongle, the xPortalNet Service showed the following message to indicate that the software is unable to detect the USB licence key.
Failed to Detect USB Key Error Message
Figure 1: Failed to Detect USB Key Error Message

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When users check the Service Info from xPortalNet Comm Service Manager icon, the Software License field is shown as "Key not detected"
About Window Showing Key Not Detected
Figure 2: About Window Showing Key Not Detected

Cause:

  • It is discovered in Device Manager that the plugged in Dongle licence is detected as both Rockey4 and Rockey4 USB 
     Device Manager Detecting the Dongle License as Rockey4 and Rockey4 USB
    Figure 3: Device Manager Detecting the Dongle License as Rockey4 and Rockey4 USB

Solution:







Summary:

  • To reinstall the Rockey4 Device Driver.


Step-by-step Guide:

  • To reinstall the Rockey4 Device Driver:

Step 1: Unplug the USB dongle license key from the USB port. Stop the xPortalNet Services.

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Step 2: Go to Device Manager. Select right-click ROCKEY4 > Uninstall device. Repeat the steps for ROCKEY4 USB.
 
Figure 4: Uninstall Device Option on ROCKEY4

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Step 3: Click here to download the driver under the Driver Update Utility section.
Click Download Now to Download the Driver Update Utility
Figure 5: Click Download Now to Download the Driver Update Utility

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Step 4: Run the downloaded driver file. The Setup Wizard window will be shown. Click Next to begin the installation process.

Figure 6: Setup Wizard Window

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Step 5: The ROCKEY Driver Installation window will then be shown. Ensure that the USB dongle license key is removed from the USB port. Click Next to continue.
ROCKEY Driver Installation Window
Figure 7: ROCKEY Driver Installation Window

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Step 6: Wait for the driver installation to complete. Once the driver has been successfully installed, the following window will be shown to prompt the users to restart the computer. Click Yes to restart the xPortalNet Server PC.
Restart Your Computer Message
Figure 8: Restart Your Computer Message

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Step 7: Run the xPortalNet Services again and validate that the software has successfully recognized the plugged in USB dongle license key.
USB Dongle License Detected Message
Figure 9: USB Dongle License Detected Message

Common Issue

NIL

Date Documentation:

27/3/2020 (Rev 1.0)

PROOF-READ

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