How to Troubleshoot the Issue where Users are Still Able to Access the Door after Card Records has been Deleted from xPortalNet Software

Problem (Issue) Statement:

How to troubleshoot the issue where users are still able to access the door after Card Records has been deleted from the xPortalNet software

Description:

Upon deleting the staff record from the software, the deleted card number is still able to access the door.

Related Software:
  • xPortalNet
Related Hardware:NIL
System Application:NIL
Symptom and Finding:

Users have already deleted the staff record from the software, but the staff is still able to access the door using the deleted card number. The software recorded the Valid Entry Access transaction in the Latest Event List window, but the user is shown as "Unlisted User".
Latest Event List Window Showing the Valid Entry Access Transaction with Unlisted User as Name of Staff
Figure 1: Latest Event List Window Showing the Valid Entry Access Transaction with Unlisted User as Name of Staff

Cause:
  • Staff record was deleted from the software, but was not deleted from the controller's memory.
Solution:

Summary:

  • To delete the staff record properly.

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Step-by-step Guide:
  • To delete the staff record properly:

Step 1: Login to xPortalNet Client. Ensure that all controller statuses are shown as "Up".

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Step 2: Add back the staff record that was deleted from the software, but not deleted from the affected controller. This step is important and must be performed to avoid a mismatch of records between the controller and the software database.

Knowledge Base Link

Users may refer to How to Add Card User in xPortalNet Software for the complete steps on how to add card user in the xPortalNet software.

Alternatively, if this situation happened to more than 1 card users, users may refer to How to Add Staff Record using Import Staff in xPortalNet Software to batch add all the affected users together.

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Step 3: Make sure the record added is smilar to the previously deleted records. Otherwise, the staff record will not be deleted correctly from the controller.
Staff Detail Setup Window Showing a Staff Record Identical to the Previous Records
Figure 2: Staff Detail Setup Window Showing a Staff Record Identical to the Previous Records

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Step 4: Once users have confirmed that the staff records at the software and the controller matches, users can then proceed to delete the affected card users.

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Step 5: The convenient way to delete multiple users would be to use the Import Staff method, but selecting the Delete Only option under Import Rules section of the Select Data Source window.
Select Data Source Window with the Delete Only Option Checked
Figure 3: Select Data Source Window with the Delete Only Option Checked

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Knowledge Base Link

Users may refer to What is The Fastest Way to Delete Selected Staff Records from The Database for the complete steps on deleting staff records using the Import Staff feature.

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Step 6: Ensure that the Delivery Report shown after the process indicates that there are no errors.
Import Staff Result Showing No Errors
Figure 4: Import Staff Result Showing No Errors

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Step 7: Users can now validate that the staff records have been deleted successfully from both the software database and the controller memory. Flash the card to the respective reader and ensure that the software recorded the transaction of Unknown Card Number in the Latest Event List window.
Latest Event List Window Showing Unknown Card Number Transaction
Figure 5: Latest Event List Window Showing Unknown Card Number Transaction

Common Issues:

NIL

Porting Date:22/01/2020

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