How to Troubleshoot the Issue Where Users Cannot Start xPortal3000 Service

Problem (Issue) Statement:

How to troubleshoot the issue where users cannot start xPortal3000 Service

Description:

Users are unable to start xPortal3000 Service as the software showed an error message.

Related Software:

  • xPortal3000

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

When users attempt to start xPortal3000 Service, the following error message is shown by the software:
Error While Trying to Start the Service Message
Figure 1: Error While Trying to Start the Service Message

Cause:

  • The software version is below xPortal3000 v3.0.0.30 and is mis-detected as a threat by the antivirus software.
  • The xPortal3000 physical folder is missing in the xPortal3000 Server PC.

Solution:







Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

  • To upgrade the software to prevent the software from being mis-detected as a threat.

  • To uninstall and re-install the software again.


Step-by-step Guide:

  • To upgrade the software to prevent the software from being mis-detected as a threat:

Step 1: Users should upgrade the software to the latest version to prevent the software from being mis-detected as a threat.

Users may refer to Misdetection of Virus in xPortal3000 Software for the complete steps to prevent the software from being mis-detected as a threat.

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  • To uninstall and re-install the software again:

Step 1: At the C:\ProgramFiles\MicroEngine\xPortal3000 folder, there should be 2 separate folders named Server and Client.
Client and Server Folders in the xPortal3000 Folder
Figure 2: Client and Server Folders in the xPortal3000 Folder

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Step 2: If any of the two folders are missing, users should uninstall the software, and re-install the software again. Go to Control Panel > Uninstall a Program. The Uninstall or change a program window will be shown. Click on MicroEngine xPortal3000 Client > Uninstall. Then, click on MicroEngine xPortal3000 Server > Uninstall.
Uninstall or Change a Program Window
Figure 3: Uninstall or Change a Program Window

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Step 3: Get the latest xPortal3000 Server and Client download link from the MicroEngine's indoor support team.

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Step 4: Install the xPortal3000 software.

Knowledge Base Link

Users may refer to How to Install xPortal3000 Software for a Fresh Installation for the complete steps to install xPortal3000 software.

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Step 5: After successfully re-installing the xPortal3000 software, run the xPortal3000 Server Configuration Manager and run the xPortal3000 Service. Ensure that the Service State is shown as Running.
xPortal3000 Server Configuration Manager
Figure 4: xPortal3000 Server Configuration Manager

Common Issue

NIL

Date Documentation:

10/4/2020 (Rev 1.0)

PROOF-READ

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