How to Troubleshoot the Issue where the Controller Status is Shown as Down in xPortalNet Software due to Incorrect Software Configuration

Problem (Issue) Statement:

How to troubleshoot the issue where the controller status is shown as down in xPortalNet software due to incorrect software configuration

Description:

During installation, testing & commissioning stage, users will mostly face issues after adding new controllers. Some of the controllers keep showing the status as Down.

Many of the users are typically unsure of the settings to be configured in xPortalNet software, and these may lead to the controller status being shown as Down.

Related Software:

  • xPortalNet Lite v1.5
  • xPortalNet Standard v1.5
  • xPortalNet PS v1.5
  • xPortalNet HS

Related Hardware:

All IP connection based controller models

  • XP- SNETv2/ XP-SNET-GAC/XP-SNET-LID
  • XP- M Series Controller
  • XP- M4L Controller
  • XP- GT3500 Controller
  • XP- GTR1500 Controller

System Application:

  • Door Access System
  • Lift Masking System
  • Vehicle Access System
  • Turnstile Access System

Symptom and Finding:

After ensuring that the model for the controller was correctly selected, the controller status is still shown as Down in xPortalNet software.
Controller Status Shown as Down in Controller Tab 
Figure 1: Controller Status Shown as Down in Controller Tab

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User then used the Command Prompt to ping the controller, and the Command Prompt is able to receive response from the controller's iP address.
Command Prompt Receiving Response from Controller IP Address 
Figure 2: Command Prompt Receiving Response from Controller IP Address

Cause:

  • The network settings or address unit between xPortalNet software and controller boards is incorrectly configured.

Solution:

Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

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Step-by-step Guide:

  • To check Connection Configuration Settings on xPortalNet:

Step 1: Go to xPortalNet Server > Server Admin > Connection Setup. The Connection Setup window will be shown. Select the respective connection of the controller with status of Down. The section as highlighted in the screenshot below will show the settings for the Connection. 
The Settings of the Connection for the Controller 
Figure 3: The Settings of the Connection for the Controller

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Step 2: Make sure that the connection details selected are correct. If the configuration is correct, continue to the next section: To check the Controller Setup in the xPortalNet software and skip step 3.
If not, click Modify to modify the configuration.
Connection Settings 
Figure 4: Connection Settings

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Step 3: After correcting the connection settings click OK to save the changes and click Close to exit the Connection Setup window. The xPortalNet services will then refresh the connection. If the controller status remains Down, users should proceed to the next section: To check Controller Configuration Settings on xPortalNet Software.

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  • To check Controller Configuration Settings on xPortalNet:

Step 1: Go to xPortalNet Server > Server Admin > System Device Setup > Controller. The Controller Setup window will be shown, select the respective controller with the status of Down and click Modify.
Controller Setup Window 
Figure 5: Controller Setup Window

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Step 2: The Edit Controller window will be shown. Ensure that the controller details selected are correct. If the configuration settings are correct, continue to the next section: To cross check the configuration setting between xPortalNet software and controller board via Web diagnostic and skip the next steps.
If the configuration settings are incorrect, modify the configuration. Click OK to save the changes.
Edit Controller Window 
Figure 6: Edit Controller Window

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Tips

  1. Check the selection of the Connection field (ensure that the Connection configuration is selected), unit no address, controller model and network type
    The Important Configuration Fields 
    Figure 7: The Important Configuration Fields
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  2. If user not sure on the correct controller model to select, users may refer to How to Troubleshoot the Issue Where the Controller Status is Shown as Down Because Users Selected the Wrong Controller Model in xPortalNet Software.

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Step 3: The following message will be shown to indicate that Record are updated. Click OK to continue.
Record Updated Window 
Figure 8: Record Updated Window

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Step 4: Click Close to exit the Controller Setup window. The following message will be shown to indicate that the Request submitted to reload Controller list. Click OK to refresh the controller list. If the controller status remains as Down, users should proceed to the next section: To check Controller Configuration Settings on xPortalNet Software.
Request Submitted to Reload Controller List Window 
Figure 9: Request Submitted to Reload Controller List Window

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  • To cross check the configuration setting between xPortalNet software and controller board via Web diagnostic:

Step 1: Open the Internet Explorer browser, type the controller IP address in the address box and press ENTER.
Typing the Controller IP Address in the Web Browser Address Box 
Figure 10: Typing the Controller IP Address in the Web Browser Address Box

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Step 2: The Window Security dialog box will be shown. Enter the User name and Password. Click OK to continue.
Windows Security Window 
Figure 11: Windows Security Window

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Step 3: Once the login is successful, the Web Diagnostic welcome page will be shown.
Web Diagnostic Welcome Page 
Figure 12: Web Diagnostic Welcome Page

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Step 4: Go to Configuration Tab >select Network.
Network Button Under Configuration Menu 
Figure 13: Network Button under Configuration Menu

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Step 5: Make sure that the connection details selected are correct. Especially Subnet mask, Gateway, Server PC's IP Address and Server & board port. Press Save Setting to save any changes made.
Network Configuration Window 
Figure 14: Network Configuration Window

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Step 6: Next, go to Configuration tab > select Input.
Input Button Under Configuration Menu 
Figure 15: Input Button Under Configuration Menu

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Step 7: The Input window will be shown as below. To confirm configuration of Address number and Enhanced Network Encryption either ON or OFF, make sure both configuration are matching with the software settings.
Input Page 
Figure 16: Input Page

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Step 8: After correcting the settings via web diagnostic, click Save Setting to save the changes made.

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Knowledge Base Link

If the Address number does not match with the software, user may refer Why does the xPortalNet Server PC is Able to Ping Controller IP Address, but Controller Status is Still Shown as Down to complete the setting.

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