How to Troubleshoot the Issue Where the Controller Status is Shown as Down Because Users Selected the Wrong Controller Model in xPortalNet Software

Problem (Issue) Statement:

How to troubleshoot the issue where the controller status is shown as down because users selected the wrong controller model in xPortalNet software

Description:

A guide to troubleshoot the issue where the controller status is shown as down because users selected the wrong controller model in xPortalNet software.

xPortalNet software can be used to manage many different controllers. Sometimes, users may select the wrong controller model in the software, and the resulting outcome is that the controller status will be shown as Down.

Related Software:

  • xPortalNet Lite v1.5
  • xPortalNet Standard v1.5
  • xPortalNet PS v1.5
  • xPortalNet HS

Related Hardware:

All IP connection based controller models

  • XP- SNETv2/ XP-SNET-GAC/XP-SNET-LID
  • XP- M Series Controller
  • XP- M4L Controller
  • XP- GT3500 Controller
  • XP- GTR1500 Controller

System Application:

  • Door Access System
  • Lift Masking System
  • Vehicle Access System
  • Turnstile Access System

Symptom and Finding:

User often faced issues where they are not sure which is the correct model to be selected in xPortalNet software during installation. Thus it will result in the controller status being shown as Down in xPortalNet software.

At xPortalNet Server > Device List > Controller tab, the controller status is shown as Down.
Controller Status Shown as Down
Figure 1: Controller Status Shown as Down

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However, upon further troubleshooting, it is discovered that the xPortalNet Server PC is able to ping the controller IP address.
Command Prompt Able to Ping Controller IP Address
Figure 2: Command Prompt Able to Ping Controller IP Address

Cause:

  • Users have selected the wrong controller model in xPortalNet software.

Solution:

Summary:

  • To check controller model via Web diagnostic.

  • To check the controller model selected on xPortalNet Server.

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Step-by-step Guide:

  • To check controller model via Web diagnostic:

Step 1: Open the Internet Explorer browser, type the controller IP address in the address box and press ENTER.
Typing the Controller IP Address in the Web Browser Address Box 
Figure 3: Typing the Controller IP Address in the Web Browser Address Box 

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Step 2: The Window Security dialog box will be shown. Enter the User name and Password and click OK to continue.
Windows Security Dialog Box 
Figure 4: Windows Security Dialog Box

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Step 3: Once the login is successful, the Web Diagnostic welcome page will be shown.
Web Diagnostic Welcome Page 
Figure 5: Web Diagnostic Welcome Page

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Step 4: User may to refer to the information shown in Device Model as the Controller Model to configure settings in xPortalNet Server.
Explanation of the Information in Device Model
Figure 6: Explanation of the Information in Device Model 

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  • To check the controller model selected on xPortal Software:

Step 1: Go to xPortalNet Server Server Admin > System Device Setup Controller. The Controller Setup window will be shown, select the specific controller and click Modify.
Selecting the Specific Controller and Clicking Modify to Check the Configuration of the Controller 
Figure 7: Selecting the Specific Controller and Clicking Modify to Check the Configuration of the Controller

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Step 3: The Edit Controller window will be shown. If user found that the selected controller Model No does not match the Device Model shown on web diagnostic, re-configure the controller so that the selected Model No. is the same as the information shown in web diagnostic.
Edit Controller Window 
Figure 8: Edit Controller Window

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Step 4: Click on the drop-down arrow for the Model No field and select the correct controller model. Click OK to continue.
Selecting the Correct Controller Model 
Figure 9: Selecting the Correct Controller Model

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Step 5: The following message window will be shown to indicate the Record Updated, click OK to be continue.
Record Updated Window 
Figure 10: Record Updated Window

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Step 6: Back at the Controller Setup window, click Close to exit the window.
Clicking Close to Exit the Controller Setup Window 
Figure 11: Clicking Close to Exit the Controller Setup Window

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Step 7: User can then monitor the controller status and ensure that the status is shown as UP in xPortalNet Server > Device List > Controller tab.
Controller Status Shown as Up 
Figure 12: Controller Status Shown as Up

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Tips

The table below shows the correct controller model to be selected in xPortalNet software to avoid the controller status from being shown as Down in the xPortalNet software.

Common Issue:

NIL

Date Documentation:

24/3/2020 (Rev 1.0)

PROOF-READ

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