How to Troubleshoot the Issue where Users are Unable to Login to xPortalNet Software After Installing the Software

Problem (Issue) Statement:

How to troubleshoot the issue where users are unable to login to xPortalNet software after installing the software

Description:

After successfully installing the xPortalNet software, users are unable to login to the xPortalNet Server.

Related Software:
  • xPortalNet
Related Hardware:NIL
System Application:NIL
Symptom and Finding:
  • Symptom 1: The following error message is shown by the xPortalNet Comm Service

    Figure 1: xPortalNet Comm Service Error: Unable to Check the Service Status! Error Message
    .
  • Symptom 2: The following message is shown by the xPortalNet Comm Service

    Figure 2: xPortalNet Comm Service Status: Stopped Message
    .
  • Symptom 3: The following error message is shown by the xPortalNet Comm Service

    Figure 3: Database Not Initialized Yet! Error Message
Cause:
  • For symptom 1: The SQL Server Database is not installed or installed incorrectly
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  • For symptom 2: The xPortalNet Service is not started
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  • For symptom 3: The xPortalNet database is not initialized yet
Solution:

Summary:

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Step-by-step Guide:
  • Symptom 1: To ensure that the SQL Server is installed correctly:

Step 1: Ensure that the SQL Server software is installed correctly.

Knowledge Base Link

Users may refer to How to Install Microsoft SQL Server Express 2014 for the complete steps on how to install Microsoft SQL Server Express 2014.

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  • Symptom 2: To run xPortalNet Service:

Step 1: Ensure that the xPortalNet Service is running before launching the xPortalNet Server or Client software application.

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Step 2: Locate and right-click the xPortalNet Service icon at the system tray. Then, click Start.
Start the xPortalNet Service
Figure 4: Start the xPortalNet Service

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Step 3: Once the xPortalNet Service is started, the Stop option becomes available, while the Start option is grayed out.
The xPortalNet Service is Started
Figure 5: The xPortalNet Service is Started

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Step 4: Users can now proceed to launch the xPortalNet Server or Client software application.

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  • Symptom 3: To initialize the database for xPortalNet software:

Step 1: Users must initialize the database for the xPortalNet software before being able to use the software.

Knowledge Base Link

Users may refer to How to Initialize xPortalNet Software Database for the complete steps on how to initialize the database for xPortalNet software.

Common Issues:

NIL

Porting Date:31/12/2019

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