How to Troubleshoot the xPortalNet Client Software Which Suddenly Showed the CliStaffAdmin.dll File is Missing Error Message

Problem (Issue) Statement:

How to troubleshoot the xPortalNet Client software which suddenly showed the CliStaffAdmin.dll File is Missing Error Message

Description:

After installing or updating to xPortalNet v1.5.0.203 software on Windows 10 operating system and running for a period of time, some of the functions such as the Visitor Sign In / Out, Acknowledgement of Alarms in Alarm List or any Access Data Settings were unable to be used by the users.

An error message will then be shown to indicate that the "CliStaffAdmin.dll" file is missing.

Related Software:

  • xPortalNet Lite v1.5.0.203
  • xPortalNet Std v1.5.0.203
  • xPortalNet PS v1.5.0.203

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

When the system users are trying to access certain functions in xPortalNet Client, the software will prompt the following error message to indicate that the "CliStaffAdmin.dll" file is missing.

Figure 1: The Error Message of "Could not load file or assembly 'CliStaffAdmin, Version=1.0.7619.16062, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified."

Cause:

The "CliStaffAdmin.dll" file was quarantined and removed from "C:\Program Files (x86)\MICROENGINE\xPortalNet PS\Client" as the Windows Real Time Virus Protection detected the xPortalNet software as providing another remote access to the PC.
Windows Real Time Virus Protection Quarantining the DLL File
Figure 2: Windows Real Time Virus Protection Quarantining the DLL File 

Solution:

Summary:

  • To add xPortalNet software to the exception folder of Real Time Virus Protection.

  • To uninstall and reinstall the xPortalNet software.

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Step-by-step Guide:

  • To add xPortalNet software to the exception folder of Real Time Virus Protection:

Step 1: Click on the Search icon at the taskbar.

Figure 3: Search Icon at the Taskbar

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Step 2: Type in the following phrase "Virus & threat protection" in the search bar. Click on the search result to open the system settings window.

Figure 4: Virus & threat protection Search Result

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Step 3: The Virus & threat protection window will then be shown. Click Manage Settings to continue.

Figure 5: Virus & threat protection Window

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Step 4: The Tamper Protection window will then be shown. Users should scroll down to find the Exclusions section, and click on Add or remove exclusions to continue.
Exclusions Section in the Tamper Protection Window
Figure 6: Exclusions Section in the Tamper Protection Window

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Step 5: The Exclusions window will then be shown. Click on the + Add an exclusion button to add a program to the exclusion list.
Exclusions Window
Figure 7: Exclusions Window

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Step 6: The following drop-down menu will then be opened. Select Folder
The Folder Selection in the Drop-down Menu
Figure 8: The Folder Selection in the Drop-down Menu

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Step 7: The Select Folder window will then be shown. Locate the "C:\Program Files (x86)\MICROENGINE\xPortalNet PS" folder. Then, click Select Folder to continue.
Select Folder Window
Figure 9: Select Folder Window

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Step 8: The User Account Control window will then be prompted. Click Yes to continue.
User Account Control Window
Figure 10: User Account Control Window

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Step 9: Back at the Exclusions window, users will be able to see that the MicroEngine folder path has been added to the exclusions list.
MicroEngine Folder Path Added to the Exclusions List
Figure 11: MicroEngine Folder Path Added to the Exclusions List

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  • To Uninstall and Reinstall xPortalNet Client:

Step 1: Open the Programs and Features settings window.

Figure 12: Program and Features Icon

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Step 2: The Uninstall or change a program window will then be shown. Locate and select MicroEngine xPortalNet Client and click Uninstall.
Uninstall or Change a Program Window
Figure 13: Uninstall or Change a Program Window

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Step 3: The Programs and Features Window will be shown to prompt users for confirmation to uninstall the software. Click Yes to continue and wait for the uninstall process to be completed.

Figure 14: Programs and Features Window

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Step 4: Then users can reinstall the xPortalNet software.

Knowledge Base Link

Users may refer to How to Install xPortalNet Software for the complete steps to install xPortalNet software.

Common Issues:

NIL

Date Documentation:

9/9/2020 (Rev 1.0)

PROOF-READ

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