How to Use TRACERT to Troubleshoot TCP-IP Problems in xPortalNet System

Problem (Issue) Statement:

How to use TRACERT to troubleshoot TCP/IP problems in xPortalNet system?

Description:

This article will guide users to use TRACERT to troubleshoot TCP/IP problems in xPortalNet system.

TRACERT (Trace route) is command-line tool, similar to Command Prompt. It is an important tool to understand networking connection problems, including packet loss and high latency issues.

If users are having trouble connecting to xPortalNet computer or MicroEngine's IP controllers, TRACERT can tell you where the problem is. It can also help to visualize the traffic path taken by an Internet Protocol (IP) packet to its destination.
Configuration Diagram of the Functionality of TRACERT 
Figure 1: Configuration Diagram of the Functionality of TRACERT

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Note

Please note that if the site is using Layer 2 network switch, this command cannot help to find the cut-off destination along the path.

Related Software:

  • Windows OS

Related Hardware:

  • MircoEngine IP Controller

System Application:

  • Door Access System
  • Vehicle Access System
  • Lift Masking System
  • Turnstile Access System

Symptom and Finding:

NIL

Cause:

For first time guide to use TRACERT to troubleshoot TCP/IP Problems in xPortalNet system.

Solution:







Summary:

  • Use the TRACERT Utility.

  • Use TRACERT to Troubleshoot.

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Step-by-step Guide:

  • Use the TRACERT Utility:

Step 1: Go to Start Menu > Search field > type CmdOpen.
Launching Command Prompt 
Figure 2: Launching Command Prompt

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Step 2: Type tracert, followed by a space then type controller of IP address and press Enter. User may see a response similar to the following.
Response by the Command Prompt  
Figure 3: Response by the Command Prompt

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Step 3: In the command prompt window, it shows the tracert command and its output; the data packet travels through five (5) router to get to host 192.168.43.1.

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Step 4: The format of each line of the output from the command prompt is as follows.
Format of the Response by the Command Prompt Using the TRACERT Command
Figure 4: Format of the Response by the Command Prompt Using the TRACERT Command


Parameter Explanation

  • Hop: Whenever a packet is passed between a routers, this is referred to as a "hop". For example, in the output above, user can see that it take 5 hops to reach from xPortalNet computer to the controller.
  • RTT1, RTT2, and RTT3: This is the round-trip time that it takes for a packet to get to a hop and back to my computer (in milliseconds). This is often referred to as latency, and is the same number you see when using ping command. TRACERT sends 3 packets to each hop and display each time, so user has some idea of how consistent (or inconsistent) the latency readings are.
  • Domain Name [IP Address]: The domain name will be shown, if available. If the domain name isn't available, only the IP address of the router is displayed. This information is useful to identify the location of a router. 

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  • Use TRACERT to Troubleshoot:

Step 1: If user received the following responses from the Command Prompt: 
Request Timed Out Message from Command Prompt 
Figure 5: Request Timed Out Message from Command Prompt

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Step 2: Based on the command prompt messages, users are able to identify where the packet stopped on the network. For example, the messages can indicate that a network / firewall issue is preventing the data packet from reaching the controller.

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Step 3: To understand the meaning of the response messages, user may refer to the knowledge base link as below.

Common Issue

NIL

Date Documentation:

14/4/2020 (Rev 1.0)

PROOF-READ

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