How to Troubleshoot the Issue Where Users are Unable to Login to xPortalNet Software

Problem (Issue) Statement:

How to troubleshoot the issue where users are unable to login to xPortalNet software

Description:

Users are unable to login to xPortalNet software as the software prompted an error message during the login.

Related Software:

  • xPortalNet

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

When users attempt to login to the xPortalNet software, the following error message is shown by the software:

Figure 1: Invalid Setting. Please Contact Administrator! Exception: A Connection Attempt Failed Because the Connected Party Did Not Properly Respond Error Message

Cause:

  • xPortalNet Service is not running
  • xPortalNet Server Connection Properties are not configured correctly
  • xPortalNet Server software port number does not match with xPortalNet Client software port number
  • xPortalNet Server and Client IP addresses were not connected to the same local area network connection
  • the network connection is unstable

Solution:







Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary:

  • To troubleshoot and solve the issue.


Step-by-step Guide:

  • To troubleshoot and solve the issue:

Step 1: Ensure that the xPortalNet Service is running
xPortalNet Service Running Message
Figure 2: xPortalNet Service Running Message

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Step 2: If the xPortalNet Service is not running, right-click on the xPortalNet Comm Service icon and click Start.
Right-clicking xPortalNet Comm Service Icon and Clicking Start
Figure 3: Right-clicking xPortalNet Comm Service Icon and Clicking Start

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Step 3: Launch xPortalNet Client. At the xPortalNet Client Login page, click Connection Setup.
Connection Setup Button in xPortalNet Client Login Page
Figure 4: Connection Setup Button in xPortalNet Client Login Page

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Step 4: The Server Connection Properties window will then be shown. If the xPortalNet Server is located at the same PC as the xPortalNet Client, select Same Computer. Otherwise, select either the xPortalNet Server PC is to be Identified by IP Address or Identified by Computer Name. Configure the xPortalNet Server PC IP Address or computer name respectively. Click OK to save the changes.
 Configuring the Server Connection Properties Window
Figure 5: Configuring the Server Connection Properties Window

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Step 5: To ensure that the network connection is stable, users are required to run the command prompt to ping the xPortalNet Server PC IP address. Ensure that the xPortalNet Server PC IP address replies to the ping from xPortalNet Client PC.
Pinging xPortalNet Server PC IP Address
Figure 6: Pinging xPortalNet Server PC IP Address

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Knowledge Base Link

Users may refer to How to Check Network Connection Using Command Prompt to Ping Controller IP Address for the complete steps to ping xPortalNet Server PC IP Address.

*The KB article is applicable to both pinging xPortalNet Server PC IP address and pinging controller IP address.

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Step 6: If all the steps above are completed successfully, users should now be able to login to xPortalNet software. The software will prompt the following window to indicate that the login was successful.
xPortalNet Client Window Showing the Server Info
Figure 7: xPortalNet Client Window Showing the Server Info

Common Issue

NIL

Date Documentation:

14/4/2020 (Rev 1.0)

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