How to Troubleshoot the Issue where xPortal2007 Cannot Initialize Database During the First Time Installation of the Software

Problem (Issue) Statement:

How to troubleshoot the issue where xPortal2007 cannot initialize database during the first time installation of the software

Description:

This article will guide users to troubleshoot the issue where xPortal2007 cannot initialize database during the first time installation of the software.

Related Software:
  • xPortal2007
Related Hardware:NIL
System Application:NIL
Symptom and Finding:

xPortal2007 prompts the following error message when users attempted to log in to the xPortal2007 Server software application.

Cause:
  • Firebird database is not correctly installed.
  • Firebird database is not running.
  • xPortal2007 was not running as Administrator
Solution:

Summary:

.

Step-by-step Guide:
  • To ensure that Firebird Server is properly installed:

Step 1: Check and ensure that Firebird Server is properly installed in the xPortal2007 Server PC.

Knowledge Base Link

Users may refer to How to install the Firebird Database v2.5 for the complete steps to install Firebird database.

.

.

  • To ensure that Firebird Server is running properly

Step 1: At the Server PC desktop, right-click your taskbar > Task Manager > Services tab > Open Services. The Services window will then be shown. Ensure that the Firebird Server status is Running.
The Service of Firebird Server in the Services Window
Figure 1: The Service of Firebird Server in the Services Window

.

Step 2: If the Firebird Server status is not running, right-click on the service and click Start.

.

.

  • To configure xPortal2007 to run as Administrator

Step 1: Right-click on xPortal2007 Server > Properties.
Right-click xPortal2007 Server Icon and Click Properties
Figure 2: Right-click xPortal2007 Server Icon and Click Properties

.

Step 2: At the Compatibility tab, tick the Run this program as an administrator tickbox.
Tick the Run This Program as an Administrator Tickbox
Figure 3: Tick the Run This Program as an Administrator Tickbox

.

Step 3: Repeat step 1 and step 2 for the xPortal2007 Client icon.

Common Issues:

NIL

Porting Date:13/02/2020

PROOF-READ

.

Related Articles.

Containing the label "xportal2007"

Filter by label

There are no items with the selected labels at this time.

.


.

© MicroEngine Technology Sdn Bhd (535550-U). All rights reserved.