How to Troubleshoot the Issue where All Staff Shown as Absent in Daily Attendance Report

Problem (Issue) Statement:

How to troubleshoot the Issue where All Staff Shown as Absent in Daily Attendance Report

Description:

After rebuilding daily attendance report, the report summary shown that all staff are absent

Related Software:
  • xPortalNet
Related Hardware:NIL
System Application:Time Attendance Mode
Symptom and Finding:

After rebuilding daily attendance report, the report summary shows that all staff are absent, as indicated by the screenshot below:
Generated Daily Attendance Report Showed Staff as Absent
Figure 1: Generated Daily Attendance Report Showed Staff as Absent

Cause:
  • Staff forgot to clock in and clock out
  • Software setting for the attendance capturing door is not configured correctly
  • Troubleshooting xPortalNet software
Solution:

Summary:

  • Ensure that the staff clocked in and out as required.

  • Ensure that the door settings in xPortalNet software is configured correctly.

  • To troubleshoot the xPortalNet software for daily attendance.

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Step-by-step Guide:
  • Ensure that the staff clocked in and out as required:

Step 1: If the staffs do not clock in and out as required at the designated controller, the software will not obtain the relevant data when generating the Attendance report.

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  • Ensure that the door settings in xPortalNet software is configured correctly:

Step 1: Go to xPortalNet Client > Data Setup > System Device Setup > Door > select the attendance capturing door > Edit. The Edit Door window will be shown. Ensure that under the Is Attendance Capturing Door field is not configured as "No. Don't include this door for attendance calculation".
Is Attendance Capturing Door Field and Available Options
Figure 2: Is Attendance Capturing Door Field and Available Options

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Step 2: Also, ensure that the Unit No field is configured correctly. For single door controllers, configure the Door Unit No as "00". Only if the controller is capable of controlling more than 1 door, configure the doors in sequence; i.e.: for door 1, Unit No. is "00"; for door 2, Unit No. is "01", and etc until for door 10, Unit No. is "09".

Incorrect Unit No Symptom

If the Door Unit No. is configured incorrectly, the software will record transactions as shown below in the Latest Event List window:

Figure 3: Door / Panel Field Showing "Door ???"


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Step 3: Make the necessary modifications and click OK to save the changes.

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  • To Troubleshoot the xPortalNet software for daily attendance:

Step 1: Ensure that the xPortalNet Service is started and has been running for a certain period. If the xPortalNet Service has not been started for a long period of time and has just been started, the controllers are still sending transaction data to the software, and thus the software has not completely received all the transaction logs yet.

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Step 2: Once the xPortalNet service has been running for some time and all transaction logs are updated in the Latest Event List window, rebuild the daily attendance again. Wait until the software prompt the message window indicating that the Attendance Rebuild Complete before getting the Daily Attendance Report.

Knowledge Base Link

Users may refer to How to Generate Daily Attendance Report in xPortalNet Software for the complete steps on how to generate Daily Attendance Report.

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xPortalNet Best Practices

We recommend users to run xPortalNet software daily to allow controllers to send the transactions to the software regularly to prevent any unwanted disruptions to the software reporting.

We also recommend users to stop the xPortalNet Service if users wished to shut down the Server PC. This will prevent any unwanted disruptions which may result in the software database getting corrupted.

Common Issues:

NIL

Porting Date:16/01/2020

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