Why are Users Unable to Login to xPortalNet Client Software with the Software Prompting the Error Message of "User Already Login"

Problem (Issue) Statement:

Why are users unable to login to xPortalNet Client Software with the Software Prompting the Error Message of "User Already Login"

Description:

System user tried to re-login to xPortalNet Client software, but were unable to login to the software. The software prompted an error message of "User Already Login".

Related Software:

  • xPortalNet PS v1.5.0.189

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

When the system user tried to re-login to xPortalNet Client, the software prompted the following error message to indicate that "User Already Login".
User Already Login Error Message
Figure 1: User Already Login Error Message

Cause:

  • The Reset Maximum Time Out option was not activated in the software.

Solution:

Summary:

  • To validate the configuration of the Reset Max. User Time Out settings.

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Step-by-step Guide:

  • To validate the configuration of the Reset Max. User Time Out settings:

Step 1: Login to xPortalNet Server software. At the Connected Software User List section, click Reset Max. User Time Out.
Connected Software User List Section
Figure 2: Connected Software User List Section

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Step 2: The Connection Time Out Setting window will then be shown. Confirm that the Max. Time Out settings are not configured to be too long. Click OK to continue.
Connection Time Out Setting Window
Figure 3: Connection Time Out Setting Window

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Note

The Max. Time Out setting will decide how long the software allows the logged in user to be inactive before the software terminates the user login.

The default value of the Max. Time Out setting will be 180 seconds (3 minutes)

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Step 3: Go back to the xPortalNet Server Latest All Activities List. Check and ensure that the software did terminate the user login who has remained inactive over the period specified in the Max. Time Out setting. The xPortalNet software should record the User Connection Terminated and User Time Out transaction. Now the same user can be relogged in to the xPortalNet Software.
User Connection Time Out and User Connection Terminated Transactions
Figure 4: User Connection Time Out and User Connection Terminated Transactions

Common Issues:

System users will not be able to login immediately using the same user account after improperly logging out from xPortalNet Client software.

Date Documentation:

5/11/2020 (Rev 1.0)

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