$customHeader
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1 Current »

Problem (Issue) Statement:

How to troubleshoot the issue where users are unable to delete controller in xPortalNet software

Description:

Users discovered that they are unable to delete controller code in xPortalNet software.

Related Software:

  • xPortal3000

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

When users attempt to delete controller code, the following error message is shown by the software:

Figure 1: Record Deletion Error! The DELETE Statement conflicted with the REFERENCE Constraint FK__tbl_Door__Ctrl_C__7C4F7684

Cause:

  • There is a door code assigned to the controller. Therefore the software does not allow users to delete the controller without first deleting the door code.

Solution:







Warning!

  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

.

.

Summary:

  • To delete the door code and then delete the controller code.


Step-by-step Guide:

  • To delete the door code and then delete the controller code:

Step 1: Ensure that the xPortalNet Service is running.

Figure 2: xPortalNet Comm Service Status: Running Message

.

Step 2: Go to xPortalNet Server > Server Admin > System Device Setup > Doorselect the door linked to the controller to be deleted > Delete.
Selecting the Door Linked to the Controller to be Deleted and Click Delete Icon
Figure 3: Selecting the Door Linked to the Controller to be Deleted and Click Delete Icon

.

Step 3: The xPortalNet software will then prompt the following message to indicate that the record has been deleted.
Record Deleted Window
Figure 4: Record Deleted Window

.

Step 4: Go to xPortalNet Server > Server Admin > System Device Setup > Controller and try to delete the controller again. The software will then prompt the following window to indicate that the controller has been deleted successfully.
Record Deleted Window
Figure 5: Record Deleted Window

Common Issue

NIL

Date Documentation:

10/4/2020 (Rev 1.0)

PROOF-READ

.

Related Articles.

Containing the label "xportalnet"

Filter by label

There are no items with the selected labels at this time.

  • No labels