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Problem (Issue) Statement:

Why users are unable to launch xPortalNet Client software after completing installation to new Client PC

Description:

NIL

Related Software:

  • xPortalNet v1.0.0.69, x86 (Customized version for Changi Business Park)

Related Hardware:

NIL

System Application:

NIL

Symptom and Finding:

After installing xPortalNet Client software and launching the Client software, the following error message of "xPortalNet Client has stopped working" is shown:
xPortalNet Client has Stopped Working Error Message
Figure 1: xPortalNet Client has Stopped Working Error Message

Cause:

It is caused by incomplete pre-requisite installation and the software is missing a manual registration of Panasonic library files.

Solution:


Warning
titleWarning!
  • Users are not recommended to run any xPortal software in Windows XP operating system as the system is unstable

  • Users are also advised to stop the xPortal Services before shutting down the Server PC to prevent any missing transaction issues.

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Summary

  • To perform the following steps.

Step-by-step Guide:

  • To perform the following steps:

Step 1: To manually install Microsoft .net Framework 1.0.


Info
titleKnowledge Base Link

Users can referĀ How to Manually Install Microsoft .NET Framework 1.1 on Windows 10, Windows 8, Windows 7, Windows Vista and Windows Server 2008


Step 2: To manually register Panasonic library file. Go to C drive > Program File(x86) > xPortalNet > Client > Panasonic and run the RegisterPanasonicLibrary.exe file.


Step 3: A message window indicating "C:\Program Files(x86)\MicroEngine\xPortalNet\Client\...\ipropsapi.ocx succeeded" will be shown in dllRegisterServer.


Step 4: Now, users should be able to login to xPortalNet Client software.

Date Documentation:

13/7/2018 (Rev 1.0)

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